summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD29
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c8ecba14aa73
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = gopchop
+ pkgdesc = Cut and merge MPEG2-PS files at GOP boundaries without reencoding.
+ pkgver = 1.1.8
+ pkgrel = 3
+ url = http://outflux.net/unix/software/GOPchop/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = pkgconfig
+ depends = libmpeg2
+ depends = libxml2
+ depends = gtk2
+ source = https://downloads.sourceforge.net/project/gopchop/GOPchop%20-%20Development/1.1.8/gopchop-1.1.8.tar.gz
+ source = http://ftp.de.debian.org/debian/pool/main/g/gopchop/gopchop_1.1.8-5.debian.tar.gz
+ md5sums = 614bd1d34960b2dc420acde423f246e1
+ md5sums = b602e55c38cfbe182d0619f8932a7f13
+
+pkgname = gopchop
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..af32a66521cb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Alister.Hood <gmail>
+# Contributor: Gergely Tamas <dice@mfa.kfki.hu>
+pkgname=gopchop
+pkgver=1.1.8
+pkgrel=3
+pkgdesc="Cut and merge MPEG2-PS files at GOP boundaries without reencoding."
+url="http://outflux.net/unix/software/GOPchop/"
+arch=('i686' 'x86_64')
+license="GPL"
+depends=('libmpeg2' 'libxml2' 'gtk2')
+makedepends=('pkgconfig')
+source=(https://downloads.sourceforge.net/project/gopchop/GOPchop%20-%20Development/1.1.8/$pkgname-$pkgver.tar.gz
+ http://ftp.de.debian.org/debian/pool/main/g/gopchop/gopchop_1.1.8-5.debian.tar.gz)
+md5sums=('614bd1d34960b2dc420acde423f246e1' 'b602e55c38cfbe182d0619f8932a7f13')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+
+ msg "Applying patches"
+ for i in $srcdir/debian/patches/*.patch; do patch -p1<$i; done
+ sed -i 's|.png||g' $pkgname.desktop
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ make DESTDIR=$pkgdir install
+}