summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD8
-rw-r--r--gost-engine.install30
3 files changed, 21 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dabe0d6c310d..269cd80861d5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -17,10 +17,9 @@ pkgbase = gost-engine
validpgpkeys = 33ED753E14757D79FA17E57DC4C1F715B2B66B95
sha256sums = SKIP
sha256sums = 04c3483d758e393d9831d2be4cee1eafd806eea15055438be7c7b4caeeccbfe6
- sha256sums = b568af932ea9bbc42b24b487280f480467be399c5e40908f6122f0ed3d6edcd6
+ sha256sums = 5da9d605aaf45af5623d96de6cc8b68fa385601beb28fcba6054aa5811b9a4f4
sha512sums = SKIP
sha512sums = 431f810f822a347135d10c99f98ed2516e6afe310def77fc9aa0b41dc0578b05e2684f77e1062ea934961720f6d11f73f27e38548bccfe61709e81f8d53c484e
- sha512sums = 071f716440e8e54dc46b9205853125591dd857f99d0b6f2614aac0d97e1a44b3048ae58798cc80a70200ce567be2cdbb5eb00b5c2c2f3fa471e39e8ff07e8f65
+ sha512sums = dbaf26e67350bd2c4ddf265f204473be02eaf74223a49d09d9c22c0adae2c1898e2c04dfbe1096694dc47cd56c4e3cf44310c5bab04c7a83e375b9665ffdf23a
pkgname = gost-engine
-
diff --git a/PKGBUILD b/PKGBUILD
index c469b7a59f05..5dd50ef3fe3d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,11 +22,11 @@ source=(
)
sha256sums=('SKIP'
- '04c3483d758e393d9831d2be4cee1eafd806eea15055438be7c7b4caeeccbfe6'
- 'b568af932ea9bbc42b24b487280f480467be399c5e40908f6122f0ed3d6edcd6')
+ '04c3483d758e393d9831d2be4cee1eafd806eea15055438be7c7b4caeeccbfe6'
+ '5da9d605aaf45af5623d96de6cc8b68fa385601beb28fcba6054aa5811b9a4f4')
sha512sums=('SKIP'
- '431f810f822a347135d10c99f98ed2516e6afe310def77fc9aa0b41dc0578b05e2684f77e1062ea934961720f6d11f73f27e38548bccfe61709e81f8d53c484e'
- '071f716440e8e54dc46b9205853125591dd857f99d0b6f2614aac0d97e1a44b3048ae58798cc80a70200ce567be2cdbb5eb00b5c2c2f3fa471e39e8ff07e8f65')
+ '431f810f822a347135d10c99f98ed2516e6afe310def77fc9aa0b41dc0578b05e2684f77e1062ea934961720f6d11f73f27e38548bccfe61709e81f8d53c484e'
+ 'dbaf26e67350bd2c4ddf265f204473be02eaf74223a49d09d9c22c0adae2c1898e2c04dfbe1096694dc47cd56c4e3cf44310c5bab04c7a83e375b9665ffdf23a')
install=${pkgname:?}.install
diff --git a/gost-engine.install b/gost-engine.install
index 028a6b3b188f..e552550dc010 100644
--- a/gost-engine.install
+++ b/gost-engine.install
@@ -7,8 +7,8 @@ post_install() {
openssl_conf=/etc/ssl/openssl.cnf
if [ ! -f ${openssl_conf} ]; then
echo "OpenSSL Configuration file ${openssl_conf} not exist!"
- echo -e "Please manually edit yours OpenSSL configuration file and add strings \E[1m\E[33mopenssl_conf=openssl_gost # Set GOST Configuration\E[0m" \
- "to the beginning and to the end \E[1m\E[33m.include \$dir/gost.cnf # Include GOST Configuration file\E[0m of the file!"
+ echo -e "Please manually edit yours OpenSSL configuration file and add strings \E[1;33mopenssl_conf=openssl_gost # Set GOST Configuration\E[0m" \
+ "to the beginning and to the end \E[1;33m.include \$dir/gost.cnf # Include GOST Configuration file\E[0m of the file!"
echo "Sample configuration file gost.cnf you are can get from /etc/ssl folder!"
exit 0
fi
@@ -45,8 +45,8 @@ post_install() {
fi
else
if ! grep -iq "openssl_conf=openssl_gost" ${openssl_conf}; then
- echo -e "\E[1m\E[33mopenssl_conf\E[0m already defined in ${openssl_conf} file!"
- echo -e "Please check ${openssl_conf} file and add string \E[1m\E[33mopenssl_conf=openssl_gost # Set GOST Configuration\E[0m" \
+ echo -e "\E[1;33mopenssl_conf\E[0m already defined in ${openssl_conf} file!"
+ echo -e "Please check ${openssl_conf} file and add string \E[1;33mopenssl_conf=openssl_gost # Set GOST Configuration\E[0m" \
"to the beginning of the ${openssl_conf} file!"
exit 0
fi
@@ -56,13 +56,13 @@ post_install() {
if ! grep -iq "\.include\s*\$dir/gost\.cnf" ${openssl_conf} ||
! grep -iq "openssl_conf=openssl_gost" ${openssl_conf}; then
echo 'OpenSSL GOST Configuration failed!'
- echo -e "Please check ${openssl_conf} file and add string \E[1m\E[33mopenssl_conf=openssl_gost # Set GOST Configuration\E[0m" \
- "to the beginning and to the end \E[1m\E[33m.include \$dir/gost.cnf # Include GOST Configuration file\E[0m of the file!"
+ echo -e "Please check ${openssl_conf} file and add string \E[1;33mopenssl_conf=openssl_gost # Set GOST Configuration\E[0m" \
+ "to the beginning and to the end \E[1;33m.include \$dir/gost.cnf # Include GOST Configuration file\E[0m of the file!"
exit 0
fi
if openssl engine | grep -iq "gost"; then
- echo -e "\E[1m\E[33mGost Engine successfully installed and OpenSSL automatic configured! All works fine!\E[0m"
+ echo -e "\E[1;33mGost Engine successfully installed and OpenSSL automatic configured! All works fine!\E[0m"
fi
}
@@ -73,8 +73,8 @@ post_remove() {
openssl_conf=/etc/ssl/openssl.cnf
if [ ! -f ${openssl_conf} ]; then
echo "OpenSSL Configuration file ${openssl_conf} not exist!"
- echo -e "Please edit yours OpenSSL Configuration file and remove strings \E[1m\E[33mopenssl_conf=openssl_gost # Set GOST Configuration\E[0m" \
- "in the beginning and in the end \E[1m\E[33m.include \$dir/gost.cnf # Include GOST Configuration file\E[0m of the file!"
+ echo -e "Please edit yours OpenSSL Configuration file and remove strings \E[1;33mopenssl_conf=openssl_gost # Set GOST Configuration\E[0m" \
+ "in the beginning and in the end \E[1;33m.include \$dir/gost.cnf # Include GOST Configuration file\E[0m of the file!"
exit 0
fi
@@ -99,10 +99,10 @@ post_remove() {
sed -i ":a;N;\$!ba;s/\n\?\(\#\s*Include\s*GOST\s*Configuration\s*file\s*\)\?\.include\s*\$dir\/gost\.cnf\s*\(\#\s*\(Include\)\?\s*GOST\s*\(Configuration\)\?\s*\(file\)\?\)\?//IM" ${openssl_conf}
fi
if ! grep -iq "\.include\s*\$dir/gost\.cnf" ${openssl_conf}; then
- echo -e "Remove include GOST Configuration file gost.cnf from ${openssl_conf} file - \E[1m\E[32mSUCCESS\E[0m"
+ echo -e "Remove include GOST Configuration file gost.cnf from ${openssl_conf} file - \E[1;32mSUCCESS\E[0m"
else
- echo -e "Remove include GOST Configuration file gost.cnf from ${openssl_conf} file - \E[1m\E[31mFAILED\E[0m" \
- "\nPlease manually remove string \E[1m\E[33m.include \$dir/gost.cnf # Include GOST Configuration file\E[0m from the OpenSSL Configuration file!"
+ echo -e "Remove include GOST Configuration file gost.cnf from ${openssl_conf} file - \E[1;31mFAILED\E[0m" \
+ "\nPlease manually remove string \E[1;33m.include \$dir/gost.cnf # Include GOST Configuration file\E[0m from the OpenSSL Configuration file!"
fi
# Remove GOST Configuration from OpenSSL Configuration file
@@ -111,10 +111,10 @@ post_remove() {
fi
if ! grep -iq "openssl_conf=openssl_gost" ${openssl_conf}; then
- echo -e "Remove GOST Configuration from OpenSSL Configuration ${openssl_conf} file - \E[1m\E[32mSUCCESS\E[0m"
+ echo -e "Remove GOST Configuration from OpenSSL Configuration ${openssl_conf} file - \E[1;32mSUCCESS\E[0m"
else
- echo -e "Remove GOST Configuration from ${openssl_conf} file - \E[1m\E[31mFAILED\E[0m" \
- "\nPlease manually remove string \E[1m\E[33mopenssl_conf=openssl_gost # Set GOST Configuration\E[0m from the OpenSSL Configuration file!"
+ echo -e "Remove GOST Configuration from ${openssl_conf} file - \E[1;31mFAILED\E[0m" \
+ "\nPlease manually remove string \E[1;33mopenssl_conf=openssl_gost # Set GOST Configuration\E[0m from the OpenSSL Configuration file!"
fi
fi