summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO36
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD142
-rw-r--r--fix-python-libdir.patch14
-rw-r--r--gpsd.conf20
5 files changed, 217 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..41297712d84f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+pkgbase = gpsd-timing
+ pkgdesc = GPS daemon and library built to support GPS timing devices
+ pkgver = 3.19
+ pkgrel = 1
+ url = http://catb.org/gpsd/
+ arch = x86_64
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = BSD
+ makedepends = scons
+ makedepends = docbook-xsl
+ makedepends = python
+ depends = python
+ depends = libusb
+ depends = bluez-libs
+ depends = pps-tools
+ depends = ntp
+ optdepends = php: generate a PHP status page for your GPS
+ optdepends = php-gd: image support for the PHP status page
+ provides = gpsd
+ conflicts = gpsd
+ backup = etc/default/gpsd
+ source = https://download.savannah.gnu.org/releases/gpsd/gpsd-3.19.tar.gz
+ source = https://download.savannah.gnu.org/releases/gpsd/gpsd-3.19.tar.gz.sig
+ source = gpsd.conf
+ source = fix-python-libdir.patch
+ validpgpkeys = EED4A0893DCC705DB309E202CCF29C7238522905
+ sha256sums = 27dd24d45b2ac69baab7933da2bf6ae5fb0be90130f67e753c110a3477155f39
+ sha256sums = SKIP
+ sha256sums = 009df48ca0a031ea5e360733570277f5b936b273e6cea793ba9097b0eff41b0a
+ sha256sums = 631cf609db1f4b26b94d324a9ca16624487781f0b8736c5c59d8c45acc5d7322
+
+pkgname = gpsd-timing
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8cdb4931517c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.pkg.tar*
+*.src.tar*
+/gpsd/
+src
+pkg
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..de8d4dff4c2d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,142 @@
+# Maintainer: Timothy Brown <sysop@timb.us>
+# Contributor: Jaroslav Lichtblau <svetlemodry@archlinux.org>
+# Contributor: Tom Gundersen <teg@jklm.no>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Giacomo Rizzo <alt@free-os.it>
+
+pkgname=gpsd-timing
+pkgver=3.19
+pkgrel=1
+pkgdesc="GPS daemon and library built to support GPS timing devices"
+provides=('gpsd')
+conflicts=('gpsd')
+arch=('x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
+url="http://catb.org/gpsd/"
+license=('BSD')
+depends=('python' 'libusb' 'bluez-libs' 'pps-tools' 'ntp')
+optdepends=('php: generate a PHP status page for your GPS'
+ 'php-gd: image support for the PHP status page')
+makedepends=('scons' 'docbook-xsl' 'python')
+backup=('etc/default/gpsd')
+source=(https://download.savannah.gnu.org/releases/"${pkgname%%-timing}"/"${pkgname%%-timing}"-$pkgver.tar.gz{,.sig}
+ "${pkgname%%-timing}".conf
+ 'fix-python-libdir.patch')
+sha256sums=('27dd24d45b2ac69baab7933da2bf6ae5fb0be90130f67e753c110a3477155f39'
+ 'SKIP'
+ '009df48ca0a031ea5e360733570277f5b936b273e6cea793ba9097b0eff41b0a'
+ '631cf609db1f4b26b94d324a9ca16624487781f0b8736c5c59d8c45acc5d7322')
+validpgpkeys=('EED4A0893DCC705DB309E202CCF29C7238522905') # Gary E. Miller <gem@rellim.com>
+# validpgpkeys=('41876B2F579463A499843D1DECC8208F8C6C738D') # Eric S. Raymond
+
+prepare() {
+ cd "${pkgname%%-timing}"-$pkgver
+ patch -p1 -i ../fix-python-libdir.patch # Fix python install dir
+}
+
+build() {
+ cd "${pkgname%%-timing}"-$pkgver
+
+ export LINKFLAGS="-lpthread ${LDFLAGS}"
+ scons minimal=yes \
+ prefix=/usr \
+ mandir=/usr/share/man \
+ includedir=/usr/include \
+ libdir=/usr/lib \
+ sysconfdir=/etc \
+ bindir=/usr/bin \
+ docdir=/usr/share/doc \
+ pkgconfig=/usr/lib/pkgconfig \
+ sbindir=/usr/bin \
+ udevdir=/usr/lib/udev \
+ reconfigure=yes \
+ control_socket=yes \
+ controlsend=yes \
+ dbus_export=yes \
+ socket_export=yes \
+ passthrough=yes \
+ gpsd_group=uucp \
+ gpsd_user=nobody \
+ implicit_link=yes \
+ shared=yes \
+ ipv6=yes \
+ leapfetch=yes \
+ libgpsmm=yes \
+ manbuild=yes \
+ max_clients=64 \
+ max_devices=4 \
+ timing=yes \
+ ncurses=yes \
+ python=yes \
+ systemd=yes \
+ gpsd=yes \
+ gpsdclients=yes \
+ fixed_port_speed=115200 \
+ bluez=yes \
+ usb=yes \
+ ntp=yes \
+ ntpshm=yes \
+ shm_export=yes \
+ pps=yes \
+ magic_hat=yes \
+ timeservice=yes \
+ oscillator=yes \
+ aivdm=no \
+ ashtech=yes \
+ earthmate=no \
+ evermore=yes \
+ fury=yes \
+ fv18=no \
+ garmin=yes \
+ garmintxt=yes \
+ geostar=no \
+ gpsclock=yes \
+ greis=yes \
+ isync=yes \
+ itrax=yes \
+ mtk3301=yes \
+ navcom=yes \
+ netfeed=yes \
+ nmea0183=yes \
+ nmea2000=yes \
+ ntrip=no \
+ oceanserver=no \
+ oncore=yes \
+ rtcm104v2=yes \
+ rtcm104v3=yes \
+ sirf=yes \
+ skytraq=yes \
+ superstar2=yes \
+ tnt=no \
+ tripmate=no \
+ tsip=yes \
+ ublox=yes
+}
+
+package() {
+ cd "${pkgname%%-timing}"-$pkgver
+
+ # Fix path in systemd files
+ sed -i 's|local/sbin|bin|' systemd/{gpsd.service,gpsdctl@.service}
+
+ export DESTDIR="${pkgdir}"
+ scons install
+
+ install -Dm755 gpsinit -t "${pkgdir}"/usr/bin
+ chmod 755 "${pkgdir}"/usr/bin/*
+
+ install -Dm644 "$srcdir/gpsd.conf" "${pkgdir}"/etc/default/gpsd
+
+ install -Dm644 "gpsd.rules" "${pkgdir}"/usr/lib/udev/rules.d/25-gpsd-usb.rules
+
+ install -Dm755 gpsd.hotplug "${pkgdir}"/usr/lib/udev/gpsd.hotplug
+
+ install -Dm644 systemd/gpsd.service "${pkgdir}"/usr/lib/systemd/system/gpsd.service
+ install -Dm644 systemd/gpsd.socket "${pkgdir}"/usr/lib/systemd/system/gpsd.socket
+ install -Dm644 systemd/gpsdctl@.service "${pkgdir}"/usr/lib/systemd/system/gpsdctl@.service
+
+ install -Dm644 gpsd.php.in "${pkgdir}"/usr/share/"${pkgname%%-timing}"/gpsd.php.in
+ install -Dm644 gpsd.php "${pkgdir}"/usr/share/"${pkgname%%-timing}"/gpsd.php
+
+ install -Dm644 COPYING "${pkgdir}"/usr/share/licenses/"${pkgname%%-timing}"/LICENSE
+} \ No newline at end of file
diff --git a/fix-python-libdir.patch b/fix-python-libdir.patch
new file mode 100644
index 000000000000..69d14b99b4b0
--- /dev/null
+++ b/fix-python-libdir.patch
@@ -0,0 +1,14 @@
+diff --git a/SConstruct b/SConstruct
+index b8f3fb1..e133ece 100644
+--- a/SConstruct
++++ b/SConstruct
+@@ -1034,8 +1034,6 @@ else:
+ # follow FHS, put in /usr/local/libXX, not /usr/libXX
+ # may be lib, lib32 or lib64
+ python_libdir = polystr(python_libdir)
+- python_libdir = python_libdir.replace("/usr/lib",
+- "/usr/local/lib")
+
+ py_config_text = config.GetPythonValue('config vars',
+ PYTHON_SYSCONFIG_IMPORT,
+
diff --git a/gpsd.conf b/gpsd.conf
new file mode 100644
index 000000000000..5ce90844903b
--- /dev/null
+++ b/gpsd.conf
@@ -0,0 +1,20 @@
+# GPSD Settings
+
+# START_DAEMON: Don't run in the foreground.
+START_DAEMON="true"
+
+# GPSD_OPTIONS: Common options, see 'man gpsd' for more!
+# -b: Opens device in read-only NMEA mode. No auto-detection or setup is performed.
+# -D: Logging verbosity. 0=Critical, 5=Everything
+# -F: Alternate path to socket file.
+# -G: Make gpsd listen on all interfaces, instead of just localhost.
+# -n: Always poll GPS, even when no clients are connected. (Forced on in this binary.)
+# -r: Use GPS time, even when no fix. Useful for devices with a battery backed RTC.
+# -S: Port number to listen on. (Default: 2947)
+GPSD_OPTIONS=""
+
+# DEVICES: Path to GPS device. ***REQUIRED***
+DEVICES=""
+
+# USBAUTO: Controls hotplug support. (Disabled because most timing GPS units will be serial.)
+USBAUTO="false"