summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.AURINFO18
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD33
3 files changed, 70 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..46c92b2a8221
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,18 @@
+pkgbase = graphclust
+ pkgdesc = structural clustering of RNA sequences
+ pkgver = 0.7.6
+ pkgrel = 2
+ url = http://www.bioinf.uni-freiburg.de/Software/GraphClust/
+ arch = x86_64
+ arch = i686
+ license = GPL3
+ depends = infernal>=1.0.2
+ depends = infernal<1.1
+ depends = rnaz
+ depends = rnashapes
+ depends = zlib
+ depends = cmfinder
+ source = http://www.bioinf.uni-freiburg.de/Software/GraphClust/GraphClust-0.7.6.tar.gz
+
+pkgname = graphclust
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a0feacc119d3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = graphclust
+ pkgdesc = structural clustering of RNA sequences
+ pkgver = 0.7.6
+ pkgrel = 2
+ url = http://www.bioinf.uni-freiburg.de/Software/GraphClust/
+ arch = x86_64
+ arch = i686
+ license = GPL3
+ depends = infernal>=1.0.2
+ depends = infernal<1.1
+ depends = rnaz
+ depends = rnashapes
+ depends = zlib
+ depends = cmfinder
+ source = http://www.bioinf.uni-freiburg.de/Software/GraphClust/GraphClust-0.7.6.tar.gz
+ md5sums = e8a2a0ad87a36accc0bbcfac09b4ff78
+
+pkgname = graphclust
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..392b5bcf04d8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Christian Krause ("wookietreiber") <kizkizzbangbang@googlemail.com>
+
+pkgname=graphclust
+pkgver=0.7.6
+pkgrel=2
+pkgdesc="structural clustering of RNA sequences"
+arch=('x86_64' 'i686')
+url="http://www.bioinf.uni-freiburg.de/Software/GraphClust/"
+license=('GPL3')
+depends=('infernal>=1.0.2' 'infernal<1.1' 'rnaz' 'rnashapes' 'zlib' 'cmfinder')
+source=("http://www.bioinf.uni-freiburg.de/Software/GraphClust/GraphClust-$pkgver.tar.gz")
+md5sums=('e8a2a0ad87a36accc0bbcfac09b4ff78')
+
+build() {
+ cd "$srcdir/GraphClust-$pkgver"
+
+ ./configure --prefix=/usr \
+ --disable-static
+
+ make
+}
+
+check() {
+ cd "$srcdir/GraphClust-$pkgver"
+
+ make check
+}
+
+package() {
+ cd "$srcdir/GraphClust-$pkgver"
+
+ make DESTDIR="$pkgdir" install
+}