summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD49
-rw-r--r--gregorio.install20
3 files changed, 95 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cc9610586c37
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = gregorio-git
+ pkgdesc = Command-line tool to typeset Gregorian chant
+ pkgver = 3.0.2.r2092.4839061
+ pkgrel = 1
+ url = http://gregorio-project.github.io
+ install = gregorio.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = python
+ makedepends = fontforge
+ depends = texlive-core
+ depends = texlive-fontsextra
+ depends = texlive-bin
+ depends = texlive-formatsextra
+ depends = texlive-latexextra
+ provides = gregorio
+ conflicts = gregorio-svn
+ conflicts = gregorio
+ conflicts = gregoriotex
+ source = gregorio-git::git+https://github.com/gregorio-project/gregorio.git#branch=develop
+ sha256sums = SKIP
+
+pkgname = gregorio-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..be1c6d726c5c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Br Anthony VanBerkum <anthonyvbop AT gmail DOT com>
+# Contributor: Br. Elijah Schwab (github - eschwab)
+pkgbase=gregorio-git
+pkgname=$pkgbase
+pkgver=3.0.2.r2092.4839061
+pkgrel=1
+pkgdesc="Command-line tool to typeset Gregorian chant"
+url=http://gregorio-project.github.io
+arch=("i686" "x86_64")
+license=("GPL")
+makedepends=("git" "python" "fontforge")
+depends=("texlive-core" "texlive-fontsextra" "texlive-bin" "texlive-formatsextra" "texlive-latexextra")
+conflicts=("gregorio-svn" "gregorio" "gregoriotex")
+provides=("gregorio")
+install=gregorio.install
+source=("$pkgbase::git+https://github.com/gregorio-project/gregorio.git#branch=develop")
+sha256sums=("SKIP")
+
+
+pkgver() {
+ cd "$srcdir/$pkgbase/"
+ _version=$(python2 VersionManager.py -c | sed -e "s/-/_/g")
+ echo $_version.r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+prepare() {
+ msg "Configuring..."
+ cd "$srcdir/$pkgbase/"
+ autoreconf -f -i
+ ./configure --prefix=/usr || return 1
+}
+
+build() {
+ msg "Compiling gregorio..."
+ cd "$srcdir/$pkgbase/"
+ make -j || return 1
+ msg "Building fonts..."
+ cd "$srcdir/$pkgbase/fonts/"
+ make -j fonts || return 1
+}
+
+package() {
+ cd "$srcdir/$pkgbase/"
+ msg "Installing gregorio..."
+ make -j DESTDIR="$pkgdir/" install || return 1
+ msg "Installing fonts and TeX files..."
+ cd "$srcdir/$pkgbase/"
+ ./install-gtex.sh dir:$pkgdir/usr/share/texmf-dist || return 1
+}
diff --git a/gregorio.install b/gregorio.install
new file mode 100644
index 000000000000..eb41a05bcee3
--- /dev/null
+++ b/gregorio.install
@@ -0,0 +1,20 @@
+# Maintainer: Anthony VanBerkum <anthonyvbop AT gmail DOT com>
+# Contributor: David Gippner davidgippner at googlemail dot com
+
+post_install() {
+ _tex_update
+}
+
+post_upgrade() {
+ _tex_update
+ echo "Be sure to check https://github.com/gregorio-project/gregorio/releases for any changes required in your TeX files."
+}
+
+post_remove() {
+ _tex_update
+}
+
+_tex_update() {
+ echo "Updating TeX database..."
+ texhash
+}