summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD40
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..795a74d14e0b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = gtk-theme-windows-longhorn-git
+ pkgdesc = Longhorn beta themes
+ pkgver = r95.8afdf4f
+ pkgrel = 1
+ url = https://github.com/Elbullazul/Longhorn-Collaboration
+ arch = any
+ license = GPL
+ makedepends = git
+ source = git+https://github.com/Elbullazul/Longhorn-Collaboration.git
+ md5sums = SKIP
+
+pkgname = gtk-theme-windows-longhorn-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..66db88729423
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Hokuto <abrahamhokuto@outlook.com>
+
+pkgname=gtk-theme-windows-longhorn-git
+pkgver=r95.8afdf4f
+pkgrel=1
+pkgdesc="Longhorn beta themes"
+arch=('any')
+url="https://github.com/Elbullazul/Longhorn-Collaboration"
+license=('GPL')
+depends=()
+makedepends=('git') # 'bzr', 'git', 'mercurial' or 'subversion'
+source=('git+https://github.com/Elbullazul/Longhorn-Collaboration.git')
+md5sums=('SKIP')
+
+# Please refer to the 'USING VCS SOURCES' section of the PKGBUILD man page for
+# a description of each element in the source array.
+
+pkgver() {
+ cd "$srcdir/Longhorn-Collaboration"
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/Longhorn-Collaboration"
+
+ rm -rf .git
+ rm Readme.md
+ rm 'Tips for themes.md'
+
+ mkdir -p "$pkgdir/usr/share/themes"
+
+ cp -r * "$pkgdir/usr/share/themes/"
+
+ find "$pkgdir/usr/share/themes/" -type d -exec \
+ chmod 755 {} \;
+
+ find "$pkgdir/usr/share/themes/" -type f -exec \
+ chmod 644 {} \;
+}