summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
2 files changed, 23 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a86e2e1ea2a7..72fa4b34ccdd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = gtk4-paper-plane
pkgdesc = GObject-based multi-platform GUI toolkit (Version required by Paper Plane)
- pkgver = 4.12.3
+ pkgver = 4.14.3
pkgrel = 1
url = https://www.gtk.org/
arch = i686
arch = x86_64
arch = armv7h
arch = aarch64
- license = LGPL
+ license = LGPL-2.1-or-later
checkdepends = weston
makedepends = git
makedepends = gobject-introspection
@@ -16,18 +16,24 @@ pkgbase = gtk4-paper-plane
makedepends = python-gobject
makedepends = sassc
makedepends = shaderc
+ makedepends = vulkan-headers
makedepends = wayland-protocols
depends = adwaita-icon-theme
+ depends = bash
depends = cairo
depends = cantarell-fonts
depends = dconf
depends = desktop-file-utils
depends = fontconfig
depends = fribidi
+ depends = gcc-libs
depends = gdk-pixbuf2
depends = glib2
+ depends = glibc
depends = graphene
+ depends = gst-plugins-base-libs
depends = gst-plugins-bad-libs
+ depends = gstreamer
depends = gtk-update-icon-cache
depends = harfbuzz
depends = iso-codes
@@ -54,13 +60,14 @@ pkgbase = gtk4-paper-plane
depends = pango
depends = shared-mime-info
depends = tracker3
+ depends = vulkan-icd-loader
depends = wayland
optdepends = evince: Default print preview command
- provides = gtk4=4.12.3
+ provides = gtk4=4.14.3
provides = libgtk-4.so
conflicts = gtk4
- source = git+https://gitlab.gnome.org/GNOME/gtk.git#commit=11ef4c8f43dca478d6acfaa31a3fea659946db26
- source = gtk-reversed-list-4.12.3.patch::https://raw.githubusercontent.com/paper-plane-developers/paper-plane/main/build-aux/gtk-reversed-list.patch
+ source = git+https://gitlab.gnome.org/GNOME/gtk.git#tag=4.14.3
+ source = gtk-reversed-list-4.14.3.patch::https://raw.githubusercontent.com/paper-plane-developers/paper-plane/main/build-aux/gtk-reversed-list.patch
source = gtk4-querymodules.hook
source = gtk4-querymodules.script
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 54049a781986..8434d896abb4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,31 @@
# Maintainer: Alisson Lauffer <alissonvitortc@gmail.com>
# Contributor: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
+# Contributor: Fabian Bornschein <fabiscafe@archlinux.org>
pkgname=gtk4-paper-plane
-pkgver=4.12.3
+pkgver=4.14.3
pkgrel=1
pkgdesc="GObject-based multi-platform GUI toolkit (Version required by Paper Plane)"
url="https://www.gtk.org/"
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
-license=(LGPL)
+license=(LGPL-2.1-or-later)
depends=(
adwaita-icon-theme
+ bash
cairo
cantarell-fonts
dconf
desktop-file-utils
fontconfig
fribidi
+ gcc-libs
gdk-pixbuf2
glib2
+ glibc
graphene
+ gst-plugins-base-libs
gst-plugins-bad-libs
+ gstreamer
gtk-update-icon-cache
harfbuzz
iso-codes
@@ -46,6 +52,7 @@ depends=(
pango
shared-mime-info
tracker3
+ vulkan-icd-loader
wayland
)
makedepends=(
@@ -56,14 +63,14 @@ makedepends=(
python-gobject
sassc
shaderc
+ vulkan-headers
wayland-protocols
)
optdepends=('evince: Default print preview command')
conflicts=(gtk4)
provides=(gtk4=$pkgver libgtk-4.so)
checkdepends=(weston)
-_commit=11ef4c8f43dca478d6acfaa31a3fea659946db26 # tags/4.12.3^0
-source=("git+https://gitlab.gnome.org/GNOME/gtk.git#commit=$_commit"
+source=("git+https://gitlab.gnome.org/GNOME/gtk.git#tag=$pkgver"
gtk-reversed-list-${pkgver}.patch::'https://raw.githubusercontent.com/paper-plane-developers/paper-plane/main/build-aux/gtk-reversed-list.patch'
gtk4-querymodules.{hook,script})
sha256sums=('SKIP'
@@ -71,18 +78,9 @@ sha256sums=('SKIP'
'a5074ffc057a3041a4f851b4b4674cfc21f3cb9cc90c5414c3e91816a5d205e9'
'92d08db5aa30bda276bc3d718e7ff9dd01dc40dcab45b359182dcc290054e24e')
-pkgver() {
- cd gtk
- git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
-}
-
prepare() {
cd gtk
- # https://bugs.archlinux.org/task/79310
- # https://gitlab.gnome.org/GNOME/gtk/-/merge_requests/6250
- git cherry-pick -n 4d7277f72c8f4915f237e36982ffd7dfba524b15
-
patch --forward --strip=1 --input="$srcdir/gtk-reversed-list-${pkgver}.patch"
}