summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD44
-rw-r--r--ncurses.patch90
3 files changed, 156 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ed098c7626c2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = gtypist-single-space
+ pkgdesc = universal typing tutor with single spaces after sentences in lessons.
+ pkgver = 2.9.5
+ pkgrel = 3
+ url = https://github.com/inaimathi/gtypist-single-space
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = emacs
+ depends = ncurses
+ depends = perl
+ provides = gtypist
+ conflicts = gtypist
+ source = ftp://ftp.gnu.org/gnu/gtypist/gtypist-2.9.5.tar.gz
+ source = https://github.com/inaimathi/gtypist-single-space/archive/f3b67b6d229a1d8c7bf0b3151eba51a885a25185.zip
+ source = ncurses.patch
+ md5sums = 6098c32890f2437384b5efe4e993fb32
+ md5sums = 492c92eb0917ec3b39567c2a9cb87514
+ md5sums = a836141e70941b7e0d3477bc8ecdecdf
+
+pkgname = gtypist-single-space
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8a9948abc395
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# $Id$
+# Maintainer: Burke Cates <burke.cates+arch@gmail.com>
+# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Ben Mazer <blm@groknil.org>
+# Contributor: Mike Douglas <code_monkey@gooeylinux.org>
+
+_pkgname=gtypist
+pkgname=gtypist-single-space
+pkgver=2.9.5
+pkgrel=3
+_overlay_hash=f3b67b6d229a1d8c7bf0b3151eba51a885a25185
+pkgdesc="universal typing tutor with single spaces after sentences in lessons."
+arch=('i686' 'x86_64')
+url="https://github.com/inaimathi/gtypist-single-space"
+license=("GPL")
+depends=('ncurses' 'perl')
+makedepends=('emacs')
+conflicts=('gtypist')
+provides=('gtypist')
+source=(ftp://ftp.gnu.org/gnu/gtypist/$_pkgname-$pkgver.tar.gz
+ https://github.com/inaimathi/gtypist-single-space/archive/$_overlay_hash.zip
+ ncurses.patch)
+md5sums=('6098c32890f2437384b5efe4e993fb32'
+ '492c92eb0917ec3b39567c2a9cb87514'
+ 'a836141e70941b7e0d3477bc8ecdecdf')
+
+prepare() {
+ cd "$srcdir"/$_pkgname-$pkgver
+ patch -p1 <"$srcdir"/ncurses.patch
+ autoreconf
+ mv "$srcdir"/"$pkgname"-"$_overlay_hash"/*.typ "$srcdir"/"$_pkgname"-"$pkgver"/lessons/
+}
+
+build() {
+ cd "$srcdir"/$_pkgname-$pkgver
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir"/$_pkgname-$pkgver
+ make prefix="$pkgdir"/usr install
+ rm -f "$pkgdir"/usr/share/info/dir
+}
diff --git a/ncurses.patch b/ncurses.patch
new file mode 100644
index 000000000000..a1c144562052
--- /dev/null
+++ b/ncurses.patch
@@ -0,0 +1,90 @@
+diff -wbBur gtypist-2.9.4/configure.ac gtypist-2.9.4.my/configure.ac
+--- gtypist-2.9.4/configure.ac 2014-02-02 15:38:40.000000000 +0400
++++ gtypist-2.9.4.my/configure.ac 2014-02-03 13:08:53.085983684 +0400
+@@ -44,20 +44,20 @@
+ AC_FUNC_STRTOD
+ AC_CHECK_FUNCS([__argz_count __argz_next __argz_stringify dcgettext getcwd getwd mempcpy memset munmap nl_langinfo setlocale stpcpy strcasecmp strchr strcspn strdup strstr strtoul])
+
+-# check for libncursesw
++# check for libncurses
+
+-AC_CHECK_HEADER(ncursesw/ncurses.h, HAVE_NCURSESW_H=1)
+-AC_CHECK_LIB(ncursesw, add_wch, HAVE_LIBNCURSESW=1)
++AC_CHECK_HEADER(ncurses.h, HAVE_NCURSESW_H=1)
++AC_CHECK_LIB(ncurses, add_wch, HAVE_LIBNCURSESW=1)
+ if test -n "$HAVE_NCURSESW_H" -a -n "$HAVE_LIBNCURSESW"; then
+- LIBS="-lncursesw $LIBS"
++ LIBS="-lncurses $LIBS"
+ else
+- echo -e "Error: both library and header files for the ncursesw library\n"\
++ echo -e "Error: both library and header files for the ncurses library\n"\
+ "are required to build this package. See INSTALL file for"\
+ "further information. On Debian/Ubuntu you need to install libncursesw5-dev."
+ exit 1;
+ fi
+ AC_SEARCH_LIBS(cbreak, tinfo, [],
+- [AC_MSG_ERROR([Can't find cbreak() in -lncursesw or -ltinfo])])
++ [AC_MSG_ERROR([Can't find cbreak() in -lncurses or -ltinfo])])
+
+
+ # iconv
+diff -wbBur gtypist-2.9.4/src/cursmenu.c gtypist-2.9.4.my/src/cursmenu.c
+--- gtypist-2.9.4/src/cursmenu.c 2013-08-18 18:36:14.000000000 +0400
++++ gtypist-2.9.4.my/src/cursmenu.c 2014-02-03 13:09:04.669316878 +0400
+@@ -24,7 +24,7 @@
+ #ifdef HAVE_PDCURSES
+ #include <curses.h>
+ #else
+-#include <ncursesw/ncurses.h>
++#include <ncurses.h>
+ #endif
+
+ #include "error.h"
+diff -wbBur gtypist-2.9.4/src/error.c gtypist-2.9.4.my/src/error.c
+--- gtypist-2.9.4/src/error.c 2013-08-18 18:36:14.000000000 +0400
++++ gtypist-2.9.4.my/src/error.c 2014-02-03 13:09:04.669316878 +0400
+@@ -25,7 +25,7 @@
+ #ifdef HAVE_PDCURSES
+ #include <curses.h>
+ #else
+-#include <ncursesw/ncurses.h>
++#include <ncurses.h>
+ #endif
+
+ #include <stdlib.h>
+diff -wbBur gtypist-2.9.4/src/gtypist.c gtypist-2.9.4.my/src/gtypist.c
+--- gtypist-2.9.4/src/gtypist.c 2013-08-18 18:36:14.000000000 +0400
++++ gtypist-2.9.4.my/src/gtypist.c 2014-02-03 13:09:04.669316878 +0400
+@@ -31,7 +31,7 @@
+ #ifdef HAVE_PDCURSES
+ #include <curses.h>
+ #else
+-#include <ncursesw/ncurses.h>
++#include <ncurses.h>
+ #endif
+
+ #include <time.h>
+diff -wbBur gtypist-2.9.4/src/script.c gtypist-2.9.4.my/src/script.c
+--- gtypist-2.9.4/src/script.c 2013-08-18 18:36:14.000000000 +0400
++++ gtypist-2.9.4.my/src/script.c 2014-02-03 13:09:04.669316878 +0400
+@@ -24,7 +24,7 @@
+ #ifdef HAVE_PDCURSES
+ #include <curses.h>
+ #else
+-#include <ncursesw/ncurses.h>
++#include <ncurses.h>
+ #endif
+
+ #include "error.h"
+diff -wbBur gtypist-2.9.4/src/utf8.c gtypist-2.9.4.my/src/utf8.c
+--- gtypist-2.9.4/src/utf8.c 2013-08-18 18:36:14.000000000 +0400
++++ gtypist-2.9.4.my/src/utf8.c 2014-02-03 13:09:04.669316878 +0400
+@@ -23,7 +23,7 @@
+ #ifdef HAVE_PDCURSES
+ #include <curses.h>
+ #else
+-#include <ncursesw/ncurses.h>
++#include <ncurses.h>
+ #endif
+
+ #include <stdlib.h>