summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD20
3 files changed, 21 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e4a4facb00d6..92b57153c54d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = guapow-staging
pkgdesc = On-demand and auto performance optimizer for Linux applications (testing branch. It may not be working properly)
pkgver = 1.3.4.RC
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/vinifmor/guapow
arch = any
license = zlib/libpng
- makedepends = git
- makedepends = python
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
makedepends = python-setuptools
depends = python
depends = python-aiofiles
@@ -17,7 +18,7 @@ pkgbase = guapow-staging
optdepends = unclutter: required for hiding the mouse cursor
provides = guapow
conflicts = guapow
- source = https://github.com/vinifmor/guapow/archive/a700c88a93dc890db8b228c325cf20a1711d8a3c.tar.gz
- sha512sums = ff08e4af6f5ffae0692869506388a37febafd7407f04574b3ae92ce3d5b7f1dc87be43900362f11e240db98902ed38a09320d0feab4ae2b5f4257edc92c95477
+ source = https://github.com/vinifmor/guapow/archive/a2ee990c61c5d3ba14d8a4c02d07f74fdbbd193b.tar.gz
+ sha512sums = e67c0d2a8df7e706da63bca01b1f235a20c02f5838a51e6733b657be82a6ac8c22430b2a02e6ce2c63dcca2f1a606133891b4b11f2a75eb7bc838c84e892a13d
pkgname = guapow-staging
diff --git a/.gitignore b/.gitignore
index eb8e0e8538dc..ca1fbf4b1d5e 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,4 +2,7 @@
*.tar.gz
*.zip
*.zst
+*.log
+pkg
+src
diff --git a/PKGBUILD b/PKGBUILD
index b866c5eae5f8..958e41dafc48 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
-# Maintainer: Vinícius Moreira <vinicius_fmoreira@hotmail.com>
+# Maintainer: Vinícius Moreira <vinicius_fmoreira at hotmail dot com>
pkgname=guapow-staging
_pkgname=guapow
pkgver=1.3.4.RC
-pkgrel=1
-_commit="a700c88a93dc890db8b228c325cf20a1711d8a3c"
+pkgrel=2
+_commit="a2ee990c61c5d3ba14d8a4c02d07f74fdbbd193b"
pkgdesc="On-demand and auto performance optimizer for Linux applications (testing branch. It may not be working properly)"
arch=('any')
url="https://github.com/vinifmor/guapow"
@@ -12,21 +12,25 @@ license=('zlib/libpng')
depends=('python' 'python-aiofiles' 'python-aiohttp' 'python-pycryptodome' 'systemd')
optdepends=('inxi: guess the window compositor',
'unclutter: required for hiding the mouse cursor')
-makedepends=('git' 'python' 'python-setuptools')
+makedepends=('python-build' 'python-installer' 'python-wheel' 'python-setuptools')
provides=($_pkgname)
conflicts=($_pkgname)
source=("${url}/archive/${_commit}.tar.gz")
-sha512sums=('ff08e4af6f5ffae0692869506388a37febafd7407f04574b3ae92ce3d5b7f1dc87be43900362f11e240db98902ed38a09320d0feab4ae2b5f4257edc92c95477')
+sha512sums=('e67c0d2a8df7e706da63bca01b1f235a20c02f5838a51e6733b657be82a6ac8c22430b2a02e6ce2c63dcca2f1a606133891b4b11f2a75eb7bc838c84e892a13d')
build() {
cd "${srcdir}/${_pkgname}-${_commit}"
- python3 setup.py build
- python3 setup.py test || return 1
+
+ # removing outdated setup files
+ rm setup.cfg setup.py requirements.txt
+
+ python -m unittest discover -s tests -t tests -v || return 1
+ python -m build --wheel --no-isolation
}
package() {
cd "${srcdir}/${_pkgname}-${_commit}"
- python3 setup.py install --root="$pkgdir" --optimize=1 || return 1
+ python -m installer --destdir="$pkgdir" dist/*.whl
mkdir -p $pkgdir/etc/$_pkgname
cp $_pkgname/dist/daemon/opt.conf $pkgdir/etc/$_pkgname/opt.conf.example