summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7dff173a99d5..8ab6377a3126 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gulkan-git
pkgdesc = A GLib library for Vulkan abstraction.
- pkgver = 0.16.0.442.54e80d2
+ pkgver = 0.16.0.r445.55721c9
pkgrel = 1
url = https://gitlab.freedesktop.org/xrdesktop/gulkan
arch = i686
@@ -10,6 +10,8 @@ pkgbase = gulkan-git
makedepends = git
makedepends = vulkan-headers
makedepends = gtk-doc
+ depends = glibc
+ depends = glib2
depends = gdk-pixbuf2
depends = vulkan-icd-loader
depends = graphene
@@ -18,11 +20,9 @@ pkgbase = gulkan-git
depends = json-glib
depends = libxkbcommon
depends = wayland
+ depends = libxcb
depends = xcb-util-keysyms
- depends = libdrm
- depends = wayland-protocols
- depends = glfw
- provides = gulkan=0.16.0.442.54e80d2
+ provides = gulkan=0.16.0.r445.55721c9
conflicts = gulkan
source = git+https://gitlab.freedesktop.org/xrdesktop/gulkan.git#branch=main
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index ca5bf011be4b..1d8b1c40b036 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,13 @@
_realname='gulkan'
pkgname="$_realname-git"
-pkgver=0.16.0.442.54e80d2
+pkgver=0.16.0.r445.55721c9
pkgrel=1
pkgdesc='A GLib library for Vulkan abstraction.'
arch=('i686' 'x86_64')
url='https://gitlab.freedesktop.org/xrdesktop/gulkan'
-depends=('gdk-pixbuf2' 'vulkan-icd-loader' 'graphene' 'cairo' 'shaderc' 'json-glib' 'libxkbcommon' 'wayland' 'xcb-util-keysyms' 'libdrm' 'wayland-protocols' 'glfw')
+depends=('glibc' 'glib2' 'gdk-pixbuf2' 'vulkan-icd-loader' 'graphene' 'cairo' 'shaderc' 'json-glib' 'libxkbcommon' 'wayland' 'libxcb' 'xcb-util-keysyms')
+# Dependencies only used for examples: 'libdrm' 'wayland-protocols' 'glfw')
provides=("$_realname="$pkgver)
conflicts=("$_realname")
makedepends=('meson' 'git' 'vulkan-headers' 'gtk-doc')
@@ -22,15 +23,13 @@ ver() {
}
pkgver() {
- cd $_realname
- hash=$(git log --pretty=format:'%h' -n 1)
- revision=$(git rev-list --count HEAD)
- echo $(ver).$revision.$hash
+ cd "$_realname"
+ printf "$(ver).r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
}
build() {
rm -rf build
- arch-meson $_realname build --libdir=lib --buildtype release -Dapi_doc=true
+ arch-meson "$_realname" build --libdir=lib --buildtype release -Dapi_doc=true
ninja -C build
}