summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD16
-rw-r--r--stack.yaml16
3 files changed, 34 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 312b576c8b8e..77b6d6022c67 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hadolint
pkgdesc = Dockerfile linter, validate inline bash, written in Haskell
- pkgver = 2.10.0
+ pkgver = 2.12.0
pkgrel = 1
url = https://github.com/hadolint/hadolint/
arch = x86_64
@@ -9,7 +9,9 @@ pkgbase = hadolint
depends = gmp
conflicts = hadolint-bin
conflicts = hadolint-git
- source = https://github.com/hadolint/hadolint/archive/refs/tags/v2.10.0.tar.gz
- sha256sums = 7a17d6227c9c087076aa890c9678956d0bc570eb662aa432a73d3e7c94f6b158
+ source = https://github.com/hadolint/hadolint/archive/refs/tags/v2.12.0.tar.gz
+ source = stack.yaml
+ sha256sums = 1f972f070fa068a8a18b62016c9cbd00df994006e069647038694fc6cde45545
+ sha256sums = b48e1b7264197c61e79cbd0225cc2ddb924afd62f6444745e33da834e9e7ff5d
pkgname = hadolint
diff --git a/PKGBUILD b/PKGBUILD
index 0d539d4bd61d..359c077ec740 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer of this PKGBUILD file: Martino Pilia <martino.pilia@gmail.com>
pkgname=hadolint
-pkgver=2.10.0
+pkgver=2.12.0
pkgrel=1
pkgdesc='Dockerfile linter, validate inline bash, written in Haskell'
url='https://github.com/hadolint/hadolint/'
@@ -9,12 +9,22 @@ license=('GPL')
depends=('gmp')
makedepends=('stack')
conflicts=('hadolint-bin' 'hadolint-git')
-source=("https://github.com/hadolint/hadolint/archive/refs/tags/v${pkgver}.tar.gz")
-sha256sums=('7a17d6227c9c087076aa890c9678956d0bc570eb662aa432a73d3e7c94f6b158')
+source=(
+ "https://github.com/hadolint/hadolint/archive/refs/tags/v${pkgver}.tar.gz"
+ "stack.yaml"
+)
+sha256sums=('1f972f070fa068a8a18b62016c9cbd00df994006e069647038694fc6cde45545'
+ 'b48e1b7264197c61e79cbd0225cc2ddb924afd62f6444745e33da834e9e7ff5d')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
+ # NOTE: the official build of hadolint switched from stack to cabal.
+ # However, it requires ghc>=9.2.x, while the version of ghc
+ # currently available on Arch is 9.0.2.
+ # For this reason, the package keeps using stack for now.
+ cp "${srcdir}/stack.yaml" .
+
stack build hadolint --flag hadolint:-static
}
diff --git a/stack.yaml b/stack.yaml
new file mode 100644
index 000000000000..2540fae0e708
--- /dev/null
+++ b/stack.yaml
@@ -0,0 +1,16 @@
+flags: {}
+extra-package-dbs: []
+packages:
+ - .
+resolver: lts-19.32
+extra-deps:
+ - ShellCheck-0.8.0
+ - colourista-0.1.0.1
+ - language-docker-11.0.0
+ - spdx-1.0.0.3
+ - hspec-2.10.6
+ - hspec-core-2.10.6
+ - hspec-discover-2.10.6
+ - stm-2.5.1.0
+ghc-options:
+ "$everything": -haddock