summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--hagrid.service1
3 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c8d48c0d768a..37cfcc7b0cc1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = hagrid-git
pkgdesc = Verifying OpenPGP keyserver, written in Rust
pkgver = r779.1d1eedc
- pkgrel = 1
+ pkgrel = 2
url = https://gitlab.com/keys.openpgp.org/hagrid
arch = x86_64
license = AGPL3
@@ -15,6 +15,6 @@ pkgbase = hagrid-git
source = git+https://gitlab.com/keys.openpgp.org/hagrid.git
source = hagrid.service
sha512sums = SKIP
- sha512sums = efb75d1f72ade22d52e4f5e60219399beb9fe60fbe43a76d3865916c2e8982594835a06b286e2fe8b7413c66dc10d94fd9fbaeadf8dfef936281cdf6d10e4925
+ sha512sums = e4e33158fd360947a64f3faee784f9a4203a171bef85ab0cee048e1df19d6c080175c6e175cfac3aeb08d56291c1c26ac473bb979c7347401338654926617781
pkgname = hagrid-git
diff --git a/PKGBUILD b/PKGBUILD
index 0fb609f0e7a7..c58ad549b3a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgver() {
# printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-pkgrel=1
+pkgrel=2
pkgdesc="Verifying OpenPGP keyserver, written in Rust"
arch=('x86_64')
url="https://gitlab.com/keys.openpgp.org/hagrid"
@@ -17,7 +17,7 @@ makedepends=('cargo' 'git' 'clang')
source=("git+https://gitlab.com/keys.openpgp.org/hagrid.git"
hagrid.service)
sha512sums=('SKIP'
- 'efb75d1f72ade22d52e4f5e60219399beb9fe60fbe43a76d3865916c2e8982594835a06b286e2fe8b7413c66dc10d94fd9fbaeadf8dfef936281cdf6d10e4925')
+ 'e6b2db1058484da3b168d38389c3d3109e8bd28381ff199997396c46513f0e4d52a7201db4c21d952bfdb7e36fc40bea36682349fe6e8d51bc808ebd9f1b0d96')
build() {
cd "hagrid"
@@ -46,9 +46,10 @@ package() {
install -Dm0644 nginx.conf "$pkgdir"/usr/share/doc/hagrid/nginx.conf
install -Dm0644 README.md "$pkgdir"/usr/share/doc/hagrid/README.md
# conf
- install -Dm0644 -o 99 -g 99 Rocket.toml "$pkgdir"/etc/hagrid/Rocket.toml
+ install -Dm0644 -o 65534 -g 65534 Rocket.toml "$pkgdir"/etc/hagrid/Rocket.toml
# set up working dir
- install -dm0755 -o 99 -g 99 "$pkgdir"/var/lib/hagrid/public
+ install -dm0755 -o 65534 -g 65534 "$pkgdir"/var/lib/hagrid
+ install -dm0755 -o 65534 -g 65534 "$pkgdir"/var/lib/hagrid/public
ln -s /usr/share/webapps/hagrid/assets "$pkgdir"/var/lib/hagrid/public/
ln -s /usr/share/webapps/hagrid/email-templates "$pkgdir"/var/lib/hagrid/
ln -s /usr/share/webapps/hagrid/errors-static "$pkgdir"/var/lib/hagrid/
diff --git a/hagrid.service b/hagrid.service
index fe0836639c4b..92a2e5e6a630 100644
--- a/hagrid.service
+++ b/hagrid.service
@@ -11,6 +11,7 @@ KillMode=mixed
TimeoutStopSec=5
User=nobody
PrivateTmp=true
+ReadWritePaths=/var/lib/hagrid/
[Install]
WantedBy=default.target