summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD12
2 files changed, 8 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 32189c81f988..103af6c7989f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,14 @@
-# Generated by makepkg 4.2.1
-# Thu Mar 12 09:10:57 UTC 2015
pkgbase = hashlibpp
pkgdesc = Hashing library
pkgver = 0.3.4
pkgrel = 2
- url = http://sourceforge.net/projects/hashlib2plus/
+ url = https://sourceforge.net/projects/hashlib2plus/
arch = i686
arch = x86_64
license = GPL
- source = http://downloads.sourceforge.net/project/hashlib2plus/0.3.4/hashlibpp_0_3_4.zip
+ source = https://downloads.sourceforge.net/project/hashlib2plus/0.3.4/hashlibpp_0_3_4.zip
source = Makefile.patch
md5sums = ea5643e92d261258ecefbb92e398c572
md5sums = 1d62e5ea8125d8a9ff054114956e2851
pkgname = hashlibpp
-
diff --git a/PKGBUILD b/PKGBUILD
index 36493b57ac25..b94760bd09a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
-# Maintainer: allspark <allspark at cyb0rg dot org>
+# Contributor: allspark <allspark at cyb0rg dot org>
pkgname=hashlibpp
pkgver=0.3.4
pkgrel=2
pkgdesc="Hashing library"
arch=('i686' 'x86_64')
-url="http://sourceforge.net/projects/hashlib2plus/"
+url="https://sourceforge.net/projects/hashlib2plus/"
license=('GPL')
groups=()
depends=()
@@ -17,15 +17,15 @@ replaces=()
backup=()
options=()
install=
-source=(http://downloads.sourceforge.net/project/hashlib2plus/$pkgver/hashlibpp_0_3_4.zip Makefile.patch)
+source=(https://downloads.sourceforge.net/project/hashlib2plus/$pkgver/hashlibpp_0_3_4.zip Makefile.patch)
noextract=()
md5sums=('ea5643e92d261258ecefbb92e398c572' '1d62e5ea8125d8a9ff054114956e2851')
build() {
cd $srcdir/hashlib2plus/trunk/src
- patch -p0 -i ../../../Makefile.patch || return 1
+ patch -p0 -i ../../../Makefile.patch
- make -j1 || return 1
+ make -j1
}
package() {
@@ -33,5 +33,5 @@ package() {
mkdir -p "$pkgdir"/usr/lib
mkdir -p "$pkgdir"/usr/include
- make DESTDIR=$pkgdir install || return 1
+ make DESTDIR=$pkgdir install
}