summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD43
-rw-r--r--haskell-blaze-builder.install24
3 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..08c0f7084e55
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = haskell-blaze-builder
+ pkgdesc = Efficient buffered output.
+ pkgver = 0.4.0.1
+ pkgrel = 1
+ url = https://github.com/lpsmith/blaze-builder
+ install = haskell-blaze-builder.install
+ arch = i686
+ arch = x86_64
+ license = custom:BSD3
+ makedepends = ghc
+ depends = haskell-bytestring
+ depends = haskell-text
+ options = strip
+ options = staticlibs
+ source = http://hackage.haskell.org/packages/archive/blaze-builder/0.4.0.1/blaze-builder-0.4.0.1.tar.gz
+ md5sums = 97fd54eb400f8f7170ec57f8b1e3e6af
+
+pkgname = haskell-blaze-builder
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..94e54d39dcf8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Daniel Nagy <danielnagy at gmx de>
+# Contributor: Daniel Micay <danielmicay@gmail.com>
+# Contributor: Arch Haskell Team <>
+# Contributor: Lex Black <autumn-wind at web dot de>
+
+pkgname=haskell-blaze-builder
+_hkgname=blaze-builder
+pkgver=0.4.0.1
+pkgrel=1
+pkgdesc="Efficient buffered output."
+url="https://github.com/lpsmith/blaze-builder"
+license=(custom:BSD3)
+arch=('i686' 'x86_64')
+makedepends=('ghc')
+depends=('haskell-bytestring' 'haskell-text')
+source=("http://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
+options=( 'strip' 'staticlibs' )
+install="$pkgname.install"
+md5sums=('97fd54eb400f8f7170ec57f8b1e3e6af')
+
+build() {
+ cd "$srcdir/$_hkgname-$pkgver"
+
+ runhaskell Setup configure -O -p --enable-split-objs --enable-shared \
+ --prefix=/usr --docdir=/usr/share/doc/$pkgname \
+ --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup build
+ runhaskell Setup haddock
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+
+package() {
+ cd "$srcdir/$_hkgname-$pkgver"
+ install -Dm744 register.sh "$pkgdir/usr/share/haskell/$pkgname/register.sh"
+ install -m744 unregister.sh "$pkgdir/usr/share/haskell/$pkgname/unregister.sh"
+ install -dm755 "$pkgdir/usr/share/doc/ghc/html/libraries"
+ ln -s /usr/share/doc/$pkgname/html "$pkgdir/usr/share/doc/ghc/html/libraries/$_hkgname"
+ runhaskell Setup copy --destdir="$pkgdir"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ rm -f "$pkgdir/usr/share/doc/$pkgname/LICENSE"
+}
diff --git a/haskell-blaze-builder.install b/haskell-blaze-builder.install
new file mode 100644
index 000000000000..1f2b9ed67dc2
--- /dev/null
+++ b/haskell-blaze-builder.install
@@ -0,0 +1,24 @@
+HS_DIR=usr/share/haskell/haskell-blaze-builder
+
+# functions
+post_install() {
+ $HS_DIR/register.sh
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}
+
+pre_upgrade() {
+ $HS_DIR/unregister.sh
+}
+
+post_upgrade() {
+ $HS_DIR/register.sh
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}
+
+pre_remove() {
+ $HS_DIR/unregister.sh
+}
+
+post_remove() {
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}