summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD37
-rw-r--r--haskell-cryptohash.install18
3 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..caaea6289680
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = haskell-cryptohash
+ pkgdesc = collection of crypto hashes, fast, pure and practical
+ pkgver = 0.11.6
+ pkgrel = 1
+ url = http://hackage.haskell.org/package/cryptohash
+ install = haskell-cryptohash.install
+ arch = i686
+ arch = x86_64
+ license = custom:BSD3
+ depends = ghc
+ depends = haskell-cereal>=0.2
+ depends = haskell-crypto-api>=0.5
+ depends = haskell-tagged>=0.1
+ depends = haskell-byteable
+ depends = haskell-bytestring
+ options = strip
+ options = staticlibs
+ source = http://hackage.haskell.org/packages/archive/cryptohash/0.11.6/cryptohash-0.11.6.tar.gz
+ md5sums = 4d9bcd1301feac3c130bd8f94df97dba
+
+pkgname = haskell-cryptohash
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f1278375dcf1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Daniel Nagy <danielnagy at gmx de>
+# Contributor: hauzer <hauzer@gmx.com>
+
+_hkgname=cryptohash
+pkgname=haskell-cryptohash
+pkgver=0.11.6
+pkgrel=1
+pkgdesc="collection of crypto hashes, fast, pure and practical"
+url="http://hackage.haskell.org/package/${_hkgname}"
+license=('custom:BSD3')
+arch=('i686' 'x86_64')
+makedepends=()
+depends=('ghc' 'haskell-cereal>=0.2' 'haskell-crypto-api>=0.5' 'haskell-tagged>=0.1' 'haskell-byteable' 'haskell-bytestring')
+options=('strip' 'staticlibs')
+source=(http://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
+install=${pkgname}.install
+md5sums=('4d9bcd1301feac3c130bd8f94df97dba')
+build() {
+ cd ${srcdir}/${_hkgname}-${pkgver}
+ runhaskell Setup configure -O ${PKGBUILD_HASKELL_ENABLE_PROFILING:+-p } --enable-split-objs --enable-shared \
+ --prefix=/usr --docdir=/usr/share/doc/${pkgname} --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup build
+ runhaskell Setup haddock
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+package() {
+ cd ${srcdir}/${_hkgname}-${pkgver}
+ install -D -m744 register.sh ${pkgdir}/usr/share/haskell/${pkgname}/register.sh
+ install -m744 unregister.sh ${pkgdir}/usr/share/haskell/${pkgname}/unregister.sh
+ install -d -m755 ${pkgdir}/usr/share/doc/ghc/html/libraries
+ ln -s /usr/share/doc/${pkgname}/html ${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}
+ runhaskell Setup copy --destdir=${pkgdir}
+ install -D -m644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ rm -f ${pkgdir}/usr/share/doc/${pkgname}/LICENSE
+}
diff --git a/haskell-cryptohash.install b/haskell-cryptohash.install
new file mode 100644
index 000000000000..cafe58d9a071
--- /dev/null
+++ b/haskell-cryptohash.install
@@ -0,0 +1,18 @@
+HS_DIR=usr/share/haskell/haskell-cryptohash
+post_install() {
+ ${HS_DIR}/register.sh
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}
+pre_upgrade() {
+ ${HS_DIR}/unregister.sh
+}
+post_upgrade() {
+ ${HS_DIR}/register.sh
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}
+pre_remove() {
+ ${HS_DIR}/unregister.sh
+}
+post_remove() {
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}