summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD47
-rw-r--r--setup.patch7
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d49a1c566e79
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = haskell-drunken-bishop
+ pkgdesc = An implementation of the Drunken Bishop visual fingerprinting algorithm
+ pkgver = 0.1.0.0
+ pkgrel = 1
+ url = https://hackage.haskell.org/package/drunken-bishop
+ arch = x86_64
+ license = BSD
+ makedepends = ghc
+ depends = ghc-libs
+ depends = haskell-puremd5
+ source = https://hackage.haskell.org/packages/archive/drunken-bishop/0.1.0.0/drunken-bishop-0.1.0.0.tar.gz
+ source = setup.patch
+ sha256sums = fe1d43b691a4c49e264ae6d87838d2ec8249e7b4b2b5709f97d5fe8f20128784
+ sha256sums = 7def91926f2e4894a7e1d6abdcb822017bf417597ffbba09a4f7c5945ccfa3b3
+
+pkgname = haskell-drunken-bishop
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..062fa5f5f467
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Marcin Serwin <marcin.serwin0@protonmail.com>
+
+_hkgname=drunken-bishop
+pkgname=haskell-drunken-bishop
+pkgver=0.1.0.0
+pkgrel=1
+pkgdesc="An implementation of the Drunken Bishop visual fingerprinting algorithm"
+url="https://hackage.haskell.org/package/drunken-bishop"
+license=("BSD")
+arch=('x86_64')
+depends=('ghc-libs' 'haskell-puremd5')
+makedepends=('ghc')
+source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz" "setup.patch")
+sha256sums=('fe1d43b691a4c49e264ae6d87838d2ec8249e7b4b2b5709f97d5fe8f20128784'
+ '7def91926f2e4894a7e1d6abdcb822017bf417597ffbba09a4f7c5945ccfa3b3')
+
+prepare() {
+ cd $_hkgname-$pkgver
+ patch --forward --strip=1 --input="${srcdir}/setup.patch"
+}
+
+build() {
+ cd $_hkgname-$pkgver
+
+ runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
+ --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
+ --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid \
+ --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
+ --ghc-option='-pie' \
+ -fno-exe
+
+ runhaskell Setup build
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+
+package() {
+ cd $_hkgname-$pkgver
+
+ install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
+ install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
+ runhaskell Setup copy --destdir="$pkgdir"
+ install -D -m644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
+ rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE
+}
diff --git a/setup.patch b/setup.patch
new file mode 100644
index 000000000000..b52f778ddaa8
--- /dev/null
+++ b/setup.patch
@@ -0,0 +1,7 @@
+diff --unified --recursive --text -N drunken-bishop-0.1.0.0.orig/Setup.hs drunken-bishop-0.1.0.0/Setup.hs
+--- drunken-bishop-0.1.0.0.orig/Setup.hs 1970-01-01 01:00:00.000000000 +0100
++++ drunken-bishop-0.1.0.0/Setup.hs 2023-03-15 19:01:11.244318434 +0100
+@@ -0,0 +1,3 @@
++import Distribution.Simple
++main = defaultMain
++