summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD41
-rw-r--r--haskell-filestore.install18
3 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9b34a08410d4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = haskell-filestore
+ pkgdesc = Interface for versioning file stores.
+ pkgver = 0.6.0.4
+ pkgrel = 1
+ url = http://hackage.haskell.org/package/filestore
+ install = haskell-filestore.install
+ arch = i686
+ arch = x86_64
+ license = custom:BSD3
+ depends = ghc
+ depends = haskell-bytestring>=0.9
+ depends = haskell-containers>=0.3
+ depends = haskell-diff>=0.2
+ depends = haskell-directory>=1.1
+ depends = haskell-filepath>=1.1
+ depends = haskell-old-locale>=1.0
+ depends = haskell-parsec>=2
+ depends = haskell-process>=1.0
+ depends = haskell-split>=0.1
+ depends = haskell-time>=1.1
+ depends = haskell-time<1.5
+ depends = haskell-utf8-string>=0.3
+ depends = haskell-xml>=1.3
+ options = strip
+ source = http://hackage.haskell.org/packages/archive/filestore/0.6.0.4/filestore-0.6.0.4.tar.gz
+ md5sums = 6a3c642305ababb722efd51088ceb91b
+
+pkgname = haskell-filestore
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..76e17d9267a7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Daniel Nagy <danielnagy at gmx de>
+# Contributor: Nicola Squartini <tensor5@gmail.com>
+
+_hkgname=filestore
+pkgname=haskell-filestore
+pkgver=0.6.0.4
+pkgrel=1
+pkgdesc="Interface for versioning file stores."
+url="http://hackage.haskell.org/package/${_hkgname}"
+license=('custom:BSD3')
+arch=('i686' 'x86_64')
+makedepends=()
+depends=('ghc' 'haskell-bytestring>=0.9' 'haskell-containers>=0.3' 'haskell-diff>=0.2'
+ 'haskell-directory>=1.1' 'haskell-filepath>=1.1'
+ 'haskell-old-locale>=1.0' 'haskell-parsec>=2' 'haskell-process>=1.0'
+ 'haskell-split>=0.1' 'haskell-time>=1.1' 'haskell-time<1.5'
+ 'haskell-utf8-string>=0.3' 'haskell-xml>=1.3')
+options=('strip')
+source=(http://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
+install=${pkgname}.install
+md5sums=('6a3c642305ababb722efd51088ceb91b')
+build() {
+ cd ${srcdir}/${_hkgname}-${pkgver}
+ runhaskell Setup configure -O ${PKGBUILD_HASKELL_ENABLE_PROFILING:+-p } --enable-split-objs --enable-shared \
+ --prefix=/usr --docdir=/usr/share/doc/${pkgname} --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup build
+ runhaskell Setup haddock
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+package() {
+ cd ${srcdir}/${_hkgname}-${pkgver}
+ install -D -m744 register.sh ${pkgdir}/usr/share/haskell/${pkgname}/register.sh
+ install -m744 unregister.sh ${pkgdir}/usr/share/haskell/${pkgname}/unregister.sh
+ install -d -m755 ${pkgdir}/usr/share/doc/ghc/html/libraries
+ ln -s /usr/share/doc/${pkgname}/html ${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}
+ runhaskell Setup copy --destdir=${pkgdir}
+ install -D -m644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ rm -f ${pkgdir}/usr/share/doc/${pkgname}/LICENSE
+}
diff --git a/haskell-filestore.install b/haskell-filestore.install
new file mode 100644
index 000000000000..88d2e10e6546
--- /dev/null
+++ b/haskell-filestore.install
@@ -0,0 +1,18 @@
+HS_DIR=usr/share/haskell/haskell-filestore
+post_install() {
+ ${HS_DIR}/register.sh
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}
+pre_upgrade() {
+ ${HS_DIR}/unregister.sh
+}
+post_upgrade() {
+ ${HS_DIR}/register.sh
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}
+pre_remove() {
+ ${HS_DIR}/unregister.sh
+}
+post_remove() {
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}