summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--0001-update-to-support-haskell-src-exts-1.18.patch52
-rw-r--r--PKGBUILD15
3 files changed, 10 insertions, 67 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4e38f5de8798..f3a6e7d76df6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = haskell-hgettext
pkgdesc = bindings to libintl.h (gettext, bindtextdomain)
- pkgver = 0.1.30
- pkgrel = 3
+ pkgver = 0.1.31.0
+ pkgrel = 0
url = https://github.com/vasylp/hgettext
arch = x86_64
license = custom:BSD3
@@ -13,10 +13,8 @@ pkgbase = haskell-hgettext
provides = haskell-hgettext
conflicts = haskell-hgettext
options = !emptydirs
- source = http://hackage.haskell.org/packages/archive/hgettext/0.1.30/hgettext-0.1.30.tar.gz
- source = file://0001-update-to-support-haskell-src-exts-1.18.patch
- md5sums = 6b36a5c86e13de18c7daef124d9e9a71
- md5sums = d76683ac658490d60b880e6ee7928fe9
+ source = http://hackage.haskell.org/packages/archive/hgettext/0.1.31.0/hgettext-0.1.31.0.tar.gz
+ md5sums = 480acba59e114ed4a4f907695cfb60a1
pkgname = haskell-hgettext
diff --git a/0001-update-to-support-haskell-src-exts-1.18.patch b/0001-update-to-support-haskell-src-exts-1.18.patch
deleted file mode 100644
index a2d0fc038081..000000000000
--- a/0001-update-to-support-haskell-src-exts-1.18.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-From 5bf5932d6a40f5b830ffdbaa2cda2948eef52732 Mon Sep 17 00:00:00 2001
-From: Sergei Trofimovich <siarheit@google.com>
-Date: Sat, 1 Oct 2016 15:13:10 +0100
-Subject: [PATCH] update to support haskell-src-exts-1.18
-
-One of major haskell-src-exts-1.18 changes
-is to parameterise AST with source location
-and add that field to every ast node.
-
-Signed-off-by: Sergei Trofimovich <siarheit@google.com>
----
- hgettext.cabal | 2 +-
- src/hgettext.hs | 11 +++++++++--
- 2 files changed, 10 insertions(+), 3 deletions(-)
-
-diff --git a/hgettext.cabal b/hgettext.cabal
-index af934ac..37b659c 100644
---- a/hgettext.cabal
-+++ b/hgettext.cabal
-@@ -26,6 +26,6 @@ Executable hgettext
- Main-Is: hgettext.hs
- Extensions: TemplateHaskell
- Hs-Source-Dirs: src
-- Build-Depends: base>=3.0.3.0 && <5, uniplate, haskell-src-exts
-+ Build-Depends: base>=3.0.3.0 && <5, uniplate, haskell-src-exts >= 1.18
- Other-Modules: Paths_hgettext
-
-diff --git a/src/hgettext.hs b/src/hgettext.hs
-index c3b1b12..4139cae 100644
---- a/src/hgettext.hs
-+++ b/src/hgettext.hs
-@@ -49,8 +49,15 @@ parseArgs args =
- where header = "Usage: hgettext [OPTION] [INPUTFILE] ..."
-
-
--toTranslate :: String -> H.ParseResult H.Module -> [(Int, String)]
--toTranslate f (H.ParseOk z) = nub [ (0, s) | H.App (H.Var (H.UnQual (H.Ident x))) (H.Lit (H.String s)) <- universeBi z, x == f]
-+toTranslate :: String -> H.ParseResult (H.Module H.SrcSpanInfo) -> [(Int, String)]
-+toTranslate f (H.ParseOk z) = nub [ (0, s)
-+ | H.App _
-+ (H.Var _
-+ (H.UnQual _
-+ (H.Ident _ x)))
-+ (H.Lit _
-+ (H.String _ s _slit)) <- universeBi z :: [H.Exp H.SrcSpanInfo]
-+ , x == f]
- toTranslate _ _ = []
-
- -- Create list of messages from a single file
---
-2.13.1
-
diff --git a/PKGBUILD b/PKGBUILD
index 6b60d569ae24..7b79c23540db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
_ipn=hgettext
_bpn=haskell-${_ipn}
pkgname=${_bpn}
-pkgver=0.1.30
-pkgrel=3
+pkgver=0.1.31.0
+pkgrel=0
pkgdesc="bindings to libintl.h (gettext, bindtextdomain)"
arch=(x86_64)
url="https://github.com/vasylp/hgettext"
@@ -19,21 +19,18 @@ options=(!emptydirs)
install=
source=(
"http://hackage.haskell.org/packages/archive/${_ipn}/${pkgver}/${_ipn}-${pkgver}.tar.gz"
- "file://0001-update-to-support-haskell-src-exts-1.18.patch"
)
-md5sums=('6b36a5c86e13de18c7daef124d9e9a71'
- 'd76683ac658490d60b880e6ee7928fe9')
+md5sums=('480acba59e114ed4a4f907695cfb60a1')
prepare() {
cd "$srcdir/${_ipn}-${pkgver}"
- patch -Np1 -i "$srcdir/0001-update-to-support-haskell-src-exts-1.18.patch"
}
build() {
cd "$srcdir/${_ipn}-${pkgver}"
- runhaskell Setup configure -O -p --enable-split-objs --enable-shared \
- --prefix=/usr --docdir=/usr/share/doc/${pkgname} \
- --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
+ --prefix=/usr --docdir="/usr/share/doc/${pkgname}" \
+ --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid
runhaskell Setup build
runhaskell Setup haddock
runhaskell Setup register --gen-script