summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD40
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..65200b34e61f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = haskell-normaldistribution
+ pkgdesc = Produces normally distributed random values with a minimum of fuss.
+ pkgver = 1.1.0.3
+ pkgrel = 1
+ url = https://hackage.haskell.org/package/normaldistribution
+ arch = x86_64
+ license = BSD-3
+ makedepends = ghc
+ depends = ghc-libs
+ depends = haskell-random
+ source = https://hackage.haskell.org/package/normaldistribution-1.1.0.3/normaldistribution-1.1.0.3.tar.gz
+ sha512sums = 7ec4cb82436fb48663dbbe3e2849d0597f242b72e8d211515451a81cb417e26c19708ea7854a93bcce0185408fd44431349f4ab9435ca49d04f4f3f9c6a3c063
+
+pkgname = haskell-normaldistribution
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dec102fd2a68
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Jaron Kent-Dobias <jaron@kent-dobias.com>
+
+_hkgname=normaldistribution
+pkgname=haskell-normaldistribution
+pkgver=1.1.0.3
+pkgrel=1
+pkgdesc='Produces normally distributed random values with a minimum of fuss.'
+url='https://hackage.haskell.org/package/normaldistribution'
+license=('BSD-3')
+arch=('x86_64')
+depends=('ghc-libs' 'haskell-random')
+makedepends=('ghc')
+source=(https://hackage.haskell.org/package/${_hkgname}-${pkgver}/${_hkgname}-${pkgver}.tar.gz)
+sha512sums=('7ec4cb82436fb48663dbbe3e2849d0597f242b72e8d211515451a81cb417e26c19708ea7854a93bcce0185408fd44431349f4ab9435ca49d04f4f3f9c6a3c063')
+
+build() {
+ cd ${_hkgname}-${pkgver}
+ runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
+ --prefix=/usr --docdir=/usr/share/doc/$pkgname \
+ --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup build
+ runhaskell Setup haddock
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+
+package() {
+ cd ${_hkgname}-${pkgver}
+ install -Dm 744 register.sh "${pkgdir}/usr/share/haskell/register/${pkgname}.sh"
+ install -Dm 744 unregister.sh "${pkgdir}/usr/share/haskell/unregister/${pkgname}.sh"
+ install -dm 755 "${pkgdir}/usr/share/doc/ghc/html/libraries"
+ runhaskell Setup copy --destdir="$pkgdir"
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm 644 README -t "${pkgdir}/usr/share/doc/${pkgname}"
+ ln -s /usr/share/doc/${pkgname}/html "${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}"
+}
+
+# vim: ts=2 sw=2 et: