summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD37
-rw-r--r--haskell-tls-extra.install18
3 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..49a4d346a8f4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = haskell-tls-extra
+ pkgdesc = TLS extra default values and helpers
+ pkgver = 0.6.6
+ pkgrel = 2
+ url = http://hackage.haskell.org/package/tls-extra
+ install = haskell-tls-extra.install
+ arch = i686
+ arch = x86_64
+ license = custom:BSD3
+ depends = ghc
+ depends = haskell-certificate>=1.3.5
+ depends = haskell-cipher-aes>=0.2
+ depends = haskell-cipher-rc4
+ depends = haskell-crypto-pubkey
+ depends = haskell-crypto-random-api
+ depends = haskell-cryptohash>=0.6
+ depends = haskell-mtl
+ depends = haskell-network>=2.3.0.2
+ depends = haskell-pem>=0.1
+ depends = haskell-tls>=1.1.0
+ depends = haskell-vector
+ options = strip
+ options = staticlibs
+ source = http://hackage.haskell.org/packages/archive/tls-extra/0.6.6/tls-extra-0.6.6.tar.gz
+ md5sums = dd4d086abd605b9c5fe2286777eabb25
+
+pkgname = haskell-tls-extra
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..31cd3ac84dfa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Daniel Nagy <danielnagy at gmx de>
+# Contributor: hauzer <hauzer@gmx.com>
+
+_hkgname=tls-extra
+pkgname=haskell-tls-extra
+pkgver=0.6.6
+pkgrel=2
+pkgdesc="TLS extra default values and helpers"
+url="http://hackage.haskell.org/package/${_hkgname}"
+license=('custom:BSD3')
+arch=('i686' 'x86_64')
+makedepends=()
+depends=('ghc' 'haskell-certificate>=1.3.5' 'haskell-cipher-aes>=0.2' 'haskell-cipher-rc4' 'haskell-crypto-pubkey' 'haskell-crypto-random-api' 'haskell-cryptohash>=0.6' 'haskell-mtl' 'haskell-network>=2.3.0.2' 'haskell-pem>=0.1' 'haskell-tls>=1.1.0' 'haskell-vector')
+options=('strip' 'staticlibs')
+source=(http://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
+install=${pkgname}.install
+md5sums=('dd4d086abd605b9c5fe2286777eabb25')
+build() {
+ cd ${srcdir}/${_hkgname}-${pkgver}
+ runhaskell Setup configure -O ${PKGBUILD_HASKELL_ENABLE_PROFILING:+-p } --enable-split-objs --enable-shared \
+ --prefix=/usr --docdir=/usr/share/doc/${pkgname} --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup build
+ runhaskell Setup haddock
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+package() {
+ cd ${srcdir}/${_hkgname}-${pkgver}
+ install -D -m744 register.sh ${pkgdir}/usr/share/haskell/${pkgname}/register.sh
+ install -m744 unregister.sh ${pkgdir}/usr/share/haskell/${pkgname}/unregister.sh
+ install -d -m755 ${pkgdir}/usr/share/doc/ghc/html/libraries
+ ln -s /usr/share/doc/${pkgname}/html ${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}
+ runhaskell Setup copy --destdir=${pkgdir}
+ install -D -m644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ rm -f ${pkgdir}/usr/share/doc/${pkgname}/LICENSE
+}
diff --git a/haskell-tls-extra.install b/haskell-tls-extra.install
new file mode 100644
index 000000000000..f937a7020364
--- /dev/null
+++ b/haskell-tls-extra.install
@@ -0,0 +1,18 @@
+HS_DIR=usr/share/haskell/haskell-tls-extra
+post_install() {
+ ${HS_DIR}/register.sh
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}
+pre_upgrade() {
+ ${HS_DIR}/unregister.sh
+}
+post_upgrade() {
+ ${HS_DIR}/register.sh
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}
+pre_remove() {
+ ${HS_DIR}/unregister.sh
+}
+post_remove() {
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}