summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD19
-rw-r--r--kernel_4.11_fix.patch33
3 files changed, 49 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 97f8e47b9dbc..c776df85b300 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,3 +1,5 @@
+# Generated by mksrcinfo v8
+# Fri Dec 1 08:52:35 UTC 2017
pkgbase = hdjmod
pkgdesc = Hercules DJ kernel module
pkgver = 1.28
@@ -21,6 +23,7 @@ pkgbase = hdjmod
source = kernel_3.6_fix.patch
source = kernel_3.7_fix.patch
source = kernel_3.16_fix.patch
+ source = kernel_4.11_fix.patch
md5sums = 498cf0ff144f20106718932ab22571ce
md5sums = 464f8a8eda9d4c2ec83cf1c43e5dbee3
md5sums = 405a57365935fa003514ac2370325de1
@@ -31,6 +34,7 @@ pkgbase = hdjmod
md5sums = 8bf580fcfe06f48ce8247272b55633ce
md5sums = f40801f32abc47088a54c8893aa27e75
md5sums = 03b1ec1382d9d79a78cc79525cae06e4
+ md5sums = c411e703a3e6eb25d9a83399465c31d2
pkgname = hdjmod
diff --git a/PKGBUILD b/PKGBUILD
index 9e1ef73f91fb..6f78a981d718 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,7 +25,8 @@ source=('ftp://ftp.hercules.com/pub/webupdate/DJCSeries/Legacy/Hercules_DJSeries
'kernel_2.6.39_fix.patch'
'kernel_3.6_fix.patch'
'kernel_3.7_fix.patch'
- 'kernel_3.16_fix.patch')
+ 'kernel_3.16_fix.patch'
+ 'kernel_4.11_fix.patch')
md5sums=('498cf0ff144f20106718932ab22571ce'
'464f8a8eda9d4c2ec83cf1c43e5dbee3'
@@ -36,7 +37,8 @@ md5sums=('498cf0ff144f20106718932ab22571ce'
'9cc3e1cb4c7877ebf09e389e67b19182'
'8bf580fcfe06f48ce8247272b55633ce'
'f40801f32abc47088a54c8893aa27e75'
- '03b1ec1382d9d79a78cc79525cae06e4')
+ '03b1ec1382d9d79a78cc79525cae06e4'
+ 'c411e703a3e6eb25d9a83399465c31d2')
build() {
# Obtain source files
@@ -68,23 +70,26 @@ build() {
# Fifth patch fixes build errors with kernel 2.6.37
patch -p0 < $srcdir/kernel_2.6.37_fix.patch
- # Sixth patch fixes build errors with kernel 2.6.39 (from OpenSUSE Factory)
+ # Sixth patch fixes build errors with kernel 2.6.39 (by Matthias Bach <marix@marix.org>)
patch -p0 < $srcdir/kernel_2.6.39_fix.patch
- # Seventh patch fixes build errors with kernel 3.6.x (from OpenSUSE Factory)
+ # Seventh patch fixes build errors with kernel 3.6.x (by Matthias Bach <marix@marix.org>)
patch -p0 < $srcdir/kernel_3.6_fix.patch
- # Eighth patch fixes build errors with kernel 3.7.x (from OpenSUSE Factory)
+ # Eighth patch fixes build errors with kernel 3.7.x (by Matthias Bach <marix@marix.org>)
patch -p0 < $srcdir/kernel_3.7_fix.patch
# Ninth patch fixes build errors with kernel 3.16.x (by Fabian Zimmermann / fabian-zimmermann.net)
patch -p0 < $srcdir/kernel_3.16_fix.patch
+ # Another patch to fix build errors with kernel 4.11.x (by Matthias Bach <marix@marix.org>)
+ patch -p0 < $srcdir/kernel_4.11_fix.patch
+
# Fix again the path to slab.h in bulk.h
sed -i s@/usr/src/linux-$(uname -r)/include/linux/slab.h@/usr/lib/modules/$(uname -r)/build/include/linux/slab.h@ bulk.h
- # Patches 5->8 by Matthias Bach <marix@marix.org>
- # http://download.opensuse.org/repositories/hardware/openSUSE_Factory/src/
+ # Most patches borrowed from OpenSUSE maintainers:
+ # http://download.opensuse.org/repositories/hardware/openSUSE_Tumbleweed/src/
# Compile...
make
diff --git a/kernel_4.11_fix.patch b/kernel_4.11_fix.patch
new file mode 100644
index 000000000000..4d2a57fb0d87
--- /dev/null
+++ b/kernel_4.11_fix.patch
@@ -0,0 +1,33 @@
+From: Matthias Bach <marix@marix.org>
+Date: 20117-05-26 20:20:00 +0200
+Subject: Fix compile on kernel 4.11
+Upstream: to be done
+
+The module no longer compiled on 4.11
+
+diff -Naru bulk.c bulk.c
+--- bulk.c 2009-01-27 15:25:50.000000000 +0100
++++ bulk.c 2017-05-26 20:00:46.941268724 +0200
+@@ -37,6 +37,9 @@
+ #if ( LINUX_VERSION_CODE <= KERNEL_VERSION(2,6,24) )
+ #include <sound/driver.h>
+ #endif
++#if ( LINUX_VERSION_CODE >= KERNEL_VERSION(4,11,0) )
++#include <linux/sched/signal.h>
++#endif
+ #include <sound/core.h>
+ #include <sound/info.h>
+ #include <sound/initval.h>
+diff -Naru configuration_manager.c configuration_manager.c
+--- configuration_manager.c 2009-01-27 15:25:50.000000000 +0100
++++ configuration_manager.c 2017-05-26 20:02:11.079953245 +0200
+@@ -29,6 +29,9 @@
+ #if ( LINUX_VERSION_CODE <= KERNEL_VERSION(2,6,24) )
+ #include <sound/driver.h>
+ #endif
++#if ( LINUX_VERSION_CODE >= KERNEL_VERSION(4,11,0) )
++#include <linux/sched/signal.h>
++#endif
+ #include <sound/core.h>
+ #include <sound/info.h>
+ #include <sound/initval.h>