summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--0001-fix-gcc11-includes.patch11
-rw-r--r--PKGBUILD13
3 files changed, 24 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index de6115635a27..b2fb39fc076b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = heif
pkgdesc = High Efficiency Image File Format
pkgver = 3.6.2
- pkgrel = 1
+ pkgrel = 2
url = https://nokiatech.github.io/heif/
arch = x86_64
arch = i686
@@ -9,7 +9,8 @@ pkgbase = heif
makedepends = cmake
depends = gcc-libs
source = https://github.com/nokiatech/heif/archive/v3.6.2/heif-3.6.2.tar.gz
+ source = 0001-fix-gcc11-includes.patch
b2sums = b0cf8bd40b3a7b49173f129b173aebe3e2794d6bcd59c6bd453978ef68da1b68e9c09aa33fc98758ee08c2eab48e6cfa9f323b42301faa60ec87f0462c122848
+ b2sums = 71f93aac36cae3caf6460691a49d2c036084242b0fbfe7b0ac33f4499c8f901777983bb5d94b3bfb7e116fd13e67252bee9f6249cf2681dfb1bbccea3fa3b982
pkgname = heif
-
diff --git a/0001-fix-gcc11-includes.patch b/0001-fix-gcc11-includes.patch
new file mode 100644
index 000000000000..d9a1cb70182c
--- /dev/null
+++ b/0001-fix-gcc11-includes.patch
@@ -0,0 +1,11 @@
+diff --unified --recursive --text heif-3.6.2-orig/srcs/reader/heifreaderimpl.cpp heif-3.6.2/srcs/reader/heifreaderimpl.cpp
+--- heif-3.6.2-orig/srcs/reader/heifreaderimpl.cpp 2021-01-15 12:38:17.000000000 +0100
++++ heif-3.6.2/srcs/reader/heifreaderimpl.cpp 2022-03-14 12:35:21.023744580 +0100
+@@ -19,6 +19,7 @@
+ #include <cstdlib>
+ #include <cstring>
+ #include <fstream>
++#include <limits>
+
+ #include "audiosampleentrybox.hpp"
+ #include "auxiliarytypeinfobox.hpp"
diff --git a/PKGBUILD b/PKGBUILD
index 6b2c61628b5f..337dec3dbe5f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,17 @@
pkgname=heif
pkgver=3.6.2
-pkgrel=1
+pkgrel=2
pkgdesc='High Efficiency Image File Format'
arch=('x86_64' 'i686')
url='https://nokiatech.github.io/heif/'
license=('custom')
depends=('gcc-libs')
makedepends=('cmake')
-source=("https://github.com/nokiatech/heif/archive/v${pkgver}/${pkgname}-${pkgver}.tar.gz")
-b2sums=('b0cf8bd40b3a7b49173f129b173aebe3e2794d6bcd59c6bd453978ef68da1b68e9c09aa33fc98758ee08c2eab48e6cfa9f323b42301faa60ec87f0462c122848')
+source=("https://github.com/nokiatech/heif/archive/v${pkgver}/${pkgname}-${pkgver}.tar.gz"
+ "0001-fix-gcc11-includes.patch")
+b2sums=('b0cf8bd40b3a7b49173f129b173aebe3e2794d6bcd59c6bd453978ef68da1b68e9c09aa33fc98758ee08c2eab48e6cfa9f323b42301faa60ec87f0462c122848'
+ '71f93aac36cae3caf6460691a49d2c036084242b0fbfe7b0ac33f4499c8f901777983bb5d94b3bfb7e116fd13e67252bee9f6249cf2681dfb1bbccea3fa3b982')
build() {
cd ${pkgname}-${pkgver}/build/
@@ -18,6 +20,11 @@ build() {
make
}
+prepare() {
+ cd ${pkgname}-${pkgver}
+ patch --forward --strip=1 --input="${srcdir}/0001-fix-gcc11-includes.patch"
+}
+
package() {
cd ${pkgname}-${pkgver}
install -dm755 "${pkgdir}"/usr/lib/heif/