summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD35
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..edfba0dfec62
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = heir-git
+ pkgdesc = Utility to launch new terminals in the same working directory as the currently focused one under Sway.
+ pkgver = r5.4697214
+ pkgrel = 1
+ url = https://github.com/thestr4ng3r/heir
+ arch = x86_64
+ arch = aarch64
+ license = GPL3
+ depends = sway
+ depends = json-c
+ source = heir-git::git+https://github.com/thestr4ng3r/heir.git
+ source = sway::git+https://github.com/swaywm/sway.git
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = heir-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3108569b6976
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Florian Märkl <heir-aur@florianmaerkl.de>
+pkgname=heir-git
+pkgver=r5.4697214
+pkgrel=1
+pkgdesc="Utility to launch new terminals in the same working directory as the currently focused one under Sway."
+arch=("x86_64" "aarch64")
+url="https://github.com/thestr4ng3r/heir"
+license=('GPL3')
+depends=("sway" "json-c")
+source=(${pkgname}::'git+https://github.com/thestr4ng3r/heir.git'
+ sway::'git+https://github.com/swaywm/sway.git')
+md5sums=('SKIP' 'SKIP')
+
+pkgver() {
+ cd ${pkgname}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd ${pkgname}
+ git submodule init
+ git config submodule.sway.url $srcdir/sway
+ git submodule update
+}
+
+build() {
+ cd ${pkgname}
+ cmake -B build -DCMAKE_INSTALL_PREFIX=/usr
+ make -C build
+}
+
+package() {
+ cd ${pkgname}
+ make -C build DESTDIR="$pkgdir/" install
+}