summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dda815e9a9d3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = helixnotes
+ pkgdesc = Lightweight note-taker written in Python with PyGTK
+ pkgver = 0.2
+ pkgrel = 3
+ url = http://code.google.com/p/helixnotes/
+ arch = any
+ license = GPL3
+ depends = pygtk
+ depends = python2
+ source = http://www.gtk-apps.org/CONTENT/content-files/112271-helix.tar.gz
+ md5sums = af5d561ca964d86c27b433d81213a885
+
+pkgname = helixnotes
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5cd48c0ceabb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: willemw <willemw12@gmail.com>
+# Contributor: Anton Bazhenov <anton.bazhenov at gmail>
+# Contributor: Andrew Felske <knopper67@archlinux.us>
+
+pkgname=helixnotes
+pkgver=0.2
+pkgrel=3
+pkgdesc="Lightweight note-taker written in Python with PyGTK"
+arch=('any')
+url="http://code.google.com/p/helixnotes/"
+license=('GPL3')
+depends=('pygtk' 'python2')
+source=("http://www.gtk-apps.org/CONTENT/content-files/112271-helix.tar.gz")
+md5sums=('af5d561ca964d86c27b433d81213a885')
+
+package() {
+ cd helix
+ sed -i "s|bash|sh|" scripts/helix
+ sed -i "s|python|python2|" scripts/helix src/helix.py
+ sed -i "s|XDG_CONFIG_HOME|HOME/.config|" src/var.py
+ sed -i "s|XDG_DATA_HOME|HOME/.config|" src/var.py
+ python2 setup.py install --root="$pkgdir"
+}
+