summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD49
-rw-r--r--heroes-evolved.desktop10
-rw-r--r--heroes-evolved.install10
-rw-r--r--heroes-evolved.sh16
5 files changed, 111 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a312130d43c3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+# Generated by makepkg 5.0.1
+# Tue Jan 24 11:43:08 UTC 2017
+pkgbase = heroes-evolved
+ pkgdesc = Heroes Evolved is the new micro-client MOBA from R2 Games. (Wine)
+ pkgver = 1
+ pkgrel = 0
+ url = https://he.r2games.com/
+ arch = any
+ makedepends = icoutils
+ makedepends = imagemagick
+ makedepends = p7zip
+ depends = winetricks
+ depends = alsa-lib
+ depends = libldap
+ depends = lcms2
+ depends = gnutls
+ depends = mpg123
+ source = http://r2cdn2.r2games.com/en/heclient/Heroes_Evolved_Setup.exe
+ source = heroes-evolved.sh
+ source = heroes-evolved.desktop
+ sha1sums = 2e46180388228c95226999dc4a8c99a48766cc36
+ sha1sums = 52a28f17a35ba007a5963d894aff43990405bd7e
+ sha1sums = 8248b6b0e98aff79ff5cd18add6fc1329c5881e3
+
+pkgname = heroes-evolved
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..18e427ca3a8a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+pkgname=heroes-evolved
+pkgver=1
+pkgrel=0
+pkgdesc='Heroes Evolved is the new micro-client MOBA from R2 Games. (Wine)'
+url='https://he.r2games.com/'
+arch=(any)
+depends=(winetricks alsa-lib libldap lcms2 gnutls mpg123)
+depends_x86_64=(lib32-alsa-lib lib32-libldap lib32-lcms2 lib32-gnutls lib32-mpg123)
+makedepends=(icoutils imagemagick p7zip)
+
+_name='Heroes Evolved'
+_setupexe=Heroes_Evolved_Setup.exe
+# alternative full client here
+#_setupexe=Heroes_Evolved_Setup_Full.exe
+
+source=(http://r2cdn2.r2games.com/en/heclient/$_setupexe
+ heroes-evolved.sh
+ heroes-evolved.desktop)
+sha1sums=('2e46180388228c95226999dc4a8c99a48766cc36'
+ '52a28f17a35ba007a5963d894aff43990405bd7e'
+ '8248b6b0e98aff79ff5cd18add6fc1329c5881e3')
+# allow this to show the group permissions warning to user
+#install=$pkgname.install
+
+build() {
+ cd $srcdir
+ 7z x $_setupexe -o"$srcdir" -aoa
+}
+
+package() {
+ cd $srcdir
+ # games gid is 50
+ install -Dm755 -g 50 $pkgname.sh $pkgdir/usr/bin/$pkgname
+ install -Dm755 $pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
+ # setup file
+ install -Dm764 -g 50 s3ver.dat $pkgdir/opt/$pkgname/s3ver.dat
+ install -Dm764 -g 50 "Heroes Evolved.exe" "$pkgdir/opt/$pkgname/Heroes Evolved.exe"
+ install -Dm764 -g 50 HELauncher.exe $pkgdir/opt/$pkgname/HELauncher.exe
+ # data
+ cp -r app $pkgdir/opt/$pkgname/app
+ # alternative data from the full installer
+ #cp -r s3_web $pkgdir/opt/$pkgname/s3_web
+ chgrp -R 50 $pkgdir/opt/$pkgname
+ find $pkgdir/opt/$pkgname -type d -exec chmod 775 {} +
+ find $pkgdir/opt/$pkgname -type f -exec chmod 764 {} +
+ # icon
+ convert "Heroes Evolved.ico" $pkgname.png
+ install -Dm644 $pkgname-5.png $pkgdir/usr/share/pixmaps/$pkgname.png
+}
diff --git a/heroes-evolved.desktop b/heroes-evolved.desktop
new file mode 100644
index 000000000000..96f5b87b18ae
--- /dev/null
+++ b/heroes-evolved.desktop
@@ -0,0 +1,10 @@
+#!/usr/bin/env xdg-open
+[Desktop Entry]
+Version=1.0
+Name=Heroes Evolved
+Comment=Heroes Evolved is the new micro-client MOBA from R2 Games. (Wine)
+Exec=heroes-evolved
+Terminal=false
+Icon=heroes-evolved
+Type=Application
+Categories=Wine;Game;Games;
diff --git a/heroes-evolved.install b/heroes-evolved.install
new file mode 100644
index 000000000000..46f9edfd5ff8
--- /dev/null
+++ b/heroes-evolved.install
@@ -0,0 +1,10 @@
+post_install() {
+ echo 'To use heroes-evolved as a normal user, add user to the games group:'
+ echo '# gpasswd -a $USER games'
+ echo 'To make your session aware of this new group without having to log in again, you can use this command before launching heroes-evolved:'
+ echo '$ newgrp games'
+}
+
+post_upgrade() {
+ post_install
+}
diff --git a/heroes-evolved.sh b/heroes-evolved.sh
new file mode 100644
index 000000000000..1361e78d4175
--- /dev/null
+++ b/heroes-evolved.sh
@@ -0,0 +1,16 @@
+#!/usr/bin/env sh
+
+export WINEARCH=win32
+export WINEPREFIX=$HOME/.cache/heroes-evolved
+export WINEDLLOVERRIDES='wininet=b,n'
+export WINEDEBUG=-all
+
+if [[ ! -d $WINEPREFIX ]]; then
+ winetricks -q d3dx9
+ # this is for the full client, using the games permissions
+ #ln -sf /opt/heroes-evolved/s3_web "$WINEPREFIX/drive_c/users/$USER/Application Data/"
+ #ln -sf /opt/heroes-evolved/ "$WINEPREFIX/drive_c/users/$USER/Application Data/Heroes Evolved"
+ cp -r /opt/heroes-evolved/ "$WINEPREFIX/drive_c/users/$USER/Application Data/Heroes Evolved"
+fi
+
+wine "$WINEPREFIX/drive_c/users/$USER/Application Data/Heroes Evolved/Heroes Evolved.exe" &> /dev/null &