summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD30
-rw-r--r--extra-dbus-support.diff59
3 files changed, 17 insertions, 84 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 150b1be2a359..cfcf0d35ba34 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Wed Oct 17 04:09:26 UTC 2018
pkgbase = herrie-git
pkgdesc = A minimal music player.
- pkgver = 20130329
+ pkgver = 20170505
pkgrel = 1
url = http://www.herrie.info
arch = i686
@@ -16,14 +18,8 @@ pkgbase = herrie-git
depends = dbus-glib
provides = herrie
conflicts = herrie
- source = herrie-git::git://git.80386.nl/herrie
- source = extra-dbus-support.diff
+ source = herrie-git::git+https://github.com/EdSchouten/herrie
md5sums = SKIP
- md5sums = f8eebc84ffeeeeaaa3942411354cbb02
- sha1sums = SKIP
- sha1sums = fe00cab8fae31fcc7fdefc30d4f9d6680f8940df
- sha256sums = SKIP
- sha256sums = 858140e5ce4a32ed2338a0a76da361648ad32ecf4bc3baecdcb2d2bfb8ea200b
pkgname = herrie-git
diff --git a/PKGBUILD b/PKGBUILD
index 52c99a117ca0..ef3e65774acd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,18 @@
# Contributor: Joshua Stiefer <facedelajunk@gmail.com>
# Maintainer: aksr <aksr at t-com dot me>
pkgname=herrie-git
-pkgver=20130329
+pkgver=20170505
pkgrel=1
pkgdesc="A minimal music player."
arch=('i686' 'x86_64')
-url="http://www.herrie.info"
+url="http://www.herrie.info"
license=('GPL')
depends=('libmodplug' 'libsndfile' 'libid3tag' 'libxspf' 'libmad' 'curl' 'dbus-glib')
makedepends=('git')
-source=("$pkgname::git://git.80386.nl/herrie"
- 'extra-dbus-support.diff')
-provides=(herrie)
-conflicts=('herrie')
-md5sums=('SKIP'
- 'f8eebc84ffeeeeaaa3942411354cbb02')
-sha1sums=('SKIP'
- 'fe00cab8fae31fcc7fdefc30d4f9d6680f8940df')
-sha256sums=('SKIP'
- '858140e5ce4a32ed2338a0a76da361648ad32ecf4bc3baecdcb2d2bfb8ea200b')
+source=("$pkgname::git+https://github.com/EdSchouten/herrie")
+provides=("${pkgname%-*}")
+conflicts=("${pkgname%-*}")
+md5sums=('SKIP')
pkgver() {
cd "$srcdir/$pkgname"
@@ -26,18 +20,20 @@ pkgver() {
}
prepare() {
- cd "$srcdir/$pkgname"
- patch -p1 < "$srcdir/extra-dbus-support.diff"
+ cd "$srcdir/$pkgname/${pkgname%-*}"
+ # Fix from 'herrie' package
+ sed -i -e s/spiff/xspf/g -e s/SPIFF/XSPF/g -e s/Spiff/Xspf/g {configure,src/*.c}
+ sed -i s!modplug.h!libmodplug/modplug.h! src/audio_format_modplug.c
}
build() {
- cd "$srcdir/$pkgname/herrie"
+ cd "$srcdir/$pkgname/${pkgname%-*}"
./configure
make
}
package() {
- cd "$srcdir/pkgname/herrie"
- make DESTDIR="$pkgdir" install
+ cd "$srcdir/$pkgname/${pkgname%-*}"
+ make DESTDIR="$pkgdir" install
}
diff --git a/extra-dbus-support.diff b/extra-dbus-support.diff
deleted file mode 100644
index 447f9fdca27f..000000000000
--- a/extra-dbus-support.diff
+++ /dev/null
@@ -1,59 +0,0 @@
-diff --git a/herrie/src/dbus.c b/herrie/src/dbus.c
-index 640cd6b..b5c63c5 100644
---- a/herrie/src/dbus.c
-+++ b/herrie/src/dbus.c
-@@ -74,6 +74,7 @@ typedef struct {
-
- GMutex *dbus_mtx;
- static DBusServer *ds = NULL;
-+extern GString *str_song;
-
- /**
- * @brief DBus bus name used by this application.
-@@ -176,6 +177,20 @@ dbus_server_volume_up(DBusServer *self, GError **error)
- return (TRUE);
- }
-
-+/**
-+ * @brief DBus event to retrieve the currently playing song.
-+ */
-+static gboolean
-+dbus_server_get_song(DBusServer *self, gchar **song, GError **error)
-+{
-+ gui_lock();
-+ /* It is the caller's responsibility to free this. */
-+ *song = g_strdup(str_song->str);
-+ gui_unlock();
-+
-+ return (TRUE);
-+}
-+
- #include <dbus_binding.h>
-
- /**
-diff --git a/herrie/src/dbus.xml b/herrie/src/dbus.xml
-index 139e6b5..71f2272 100644
---- a/herrie/src/dbus.xml
-+++ b/herrie/src/dbus.xml
-@@ -7,5 +7,8 @@
- <method name="stop"/>
- <method name="volumeDown"/>
- <method name="volumeUp"/>
-+ <method name="getSong">
-+ <arg type="s" name="song" direction="out"/>
-+ </method>
- </interface>
- </node>
-diff --git a/herrie/src/gui_playq.c b/herrie/src/gui_playq.c
-index 4f1a43c..4c6ed84 100644
---- a/herrie/src/gui_playq.c
-+++ b/herrie/src/gui_playq.c
-@@ -51,7 +51,7 @@ static const char *str_status = NULL;
- * @brief Buffer containing a string representation of the artist and
- * title of the current song.
- */
--static GString *str_song;
-+GString *str_song;
- /**
- * @brief Window object of the status bar at the top of the screen.
- */