summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD65
2 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ebf7c63d6914
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Tue Oct 2 10:04:57 UTC 2018
+pkgbase = hexcompare
+ pkgdesc = Curses-based utility to compare and identify differences between two binary files
+ pkgver = 1.0.4
+ pkgrel = 1
+ url = https://sourceforge.net/projects/hexcompare/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = ncurses
+ source = git+https://github.com/svn2github/hexcompare.git
+ md5sums = SKIP
+
+pkgname = hexcompare
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..630cc5159449
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,65 @@
+#
+# PKGBUILD for hexcompare
+#
+# Contributor: Uffe Jakobsen <microtop@starion.dk>
+# Maintainer: Uffe Jakobsen <microtop@starion.dk>
+#
+pkgname=hexcompare
+pkgver=1.0.4
+pkgrel=1
+epoch=
+_pkgname=hexcompare
+_pkgver=${pkgver}
+pkgdesc="Curses-based utility to compare and identify differences between two binary files"
+arch=("i686" "x86_64")
+url="https://sourceforge.net/projects/hexcompare/"
+license=("GPL3")
+groups=()
+depends=("ncurses")
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+noextract=()
+_srcdirname="${pkgname}/tags/v${pkgver}"
+source=("git+https://github.com/svn2github/hexcompare.git")
+md5sums=("SKIP")
+
+#
+#
+#
+
+#pkgver() {
+# cd "${srcdir}/${_srcdirname}"
+# printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+#}
+
+
+prepare() {
+ cd "${srcdir}/${_srcdirname}"
+}
+
+build() {
+ cd "${srcdir}/${_srcdirname}"
+ make
+}
+
+check() {
+ cd "${srcdir}/${_srcdirname}"
+}
+
+package() {
+ cd "${srcdir}/${_srcdirname}"
+ install -m755 -D hexcompare "${pkgdir}/usr/bin/hexcompare"
+ install -m755 -D README "${pkgdir}/usr/share/doc/${pkgname}/README"
+}
+
+#
+# EOF
+#