summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD19
2 files changed, 15 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7c121ebe0cfd..d37b93406f89 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
pkgbase = hgweb
pkgdesc = Mercurial web interface
- pkgver = 3.4.1
+ pkgver = 6.2.1
pkgrel = 1
- url = http://mercurial.selenic.com/
+ url = https://mercurial-scm.org/
arch = any
license = GPL
depends = mercurial
- depends = python2
+ depends = python
backup = etc/conf.d/hgweb.conf
- source = http://mercurial.selenic.com/release/mercurial-3.4.1.tar.gz
+ source = https://mercurial-scm.org/release/mercurial-6.2.1.tar.gz
source = hgweb.conf
- sha256sums = 7a8acf7329beda38ceea29c689212574d9a6bfffe24cf565015ea0066f7cee3f
+ sha256sums = 8ac5d7a20d1c2ad54d4c263d134164646dc34a8e3a6bed69cfbeabaf8d3882da
sha256sums = ceccc16a49d074f4981297041f0f526c04838cd8541ecc891d87513f8a8ba62f
pkgname = hgweb
-
diff --git a/PKGBUILD b/PKGBUILD
index 3672c7f2c042..2e22e43ce4f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,26 @@
-# Maintainer: Christian Hesse <mail@eworm.de>
+# Maintainer: libele <libele@disroot.org>
+# Contributor: Christian Hesse <mail@eworm.de>
pkgname=hgweb
-pkgver=3.4.1
+pkgver=6.2.1
pkgrel=1
pkgdesc='Mercurial web interface'
arch=('any')
-url='http://mercurial.selenic.com/'
+url='https://mercurial-scm.org/'
license=('GPL')
-depends=('mercurial' 'python2')
-source=("http://mercurial.selenic.com/release/mercurial-${pkgver}.tar.gz"
+depends=('mercurial' 'python')
+source=("https://mercurial-scm.org/release/mercurial-${pkgver}.tar.gz"
'hgweb.conf')
backup=('etc/conf.d/hgweb.conf')
-sha256sums=('7a8acf7329beda38ceea29c689212574d9a6bfffe24cf565015ea0066f7cee3f'
+sha256sums=('8ac5d7a20d1c2ad54d4c263d134164646dc34a8e3a6bed69cfbeabaf8d3882da'
'ceccc16a49d074f4981297041f0f526c04838cd8541ecc891d87513f8a8ba62f')
build() {
- sed -i -e '/#!/s|python|python2|' -e '/^config/c config = "/etc/conf.d/hgweb.conf"' ${srcdir}/mercurial-${pkgver}/hgweb.cgi
+ sed -i -e '/^config/c config = b"/etc/conf.d/hgweb.conf"' ${srcdir}/mercurial-${pkgver}/hgweb.cgi
}
package() {
- install -D -m0755 ${srcdir}/mercurial-${pkgver}/hgweb.cgi ${pkgdir}/srv/http/hg/hgweb.cgi
- install -D -m0644 ${srcdir}/hgweb.conf ${pkgdir}/etc/conf.d/hgweb.conf
+ install -Dm755 ${srcdir}/mercurial-${pkgver}/hgweb.cgi ${pkgdir}/usr/share/webapps/hgweb/hgweb.cgi
+ install -Dm644 ${srcdir}/hgweb.conf ${pkgdir}/etc/conf.d/hgweb.conf
}