summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2ce727c9ade6..0d7f2b046232 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,9 +8,9 @@ pkgbase = hitch-git
license = GPL
makedepends = git
makedepends = lsof
+ makedepends = python-docutils
depends = libev
depends = openssl
- depends = python-docutils
provides = hitch
conflicts = hitch
source = git+http://git.1wt.eu/git/ebtree.git/
diff --git a/PKGBUILD b/PKGBUILD
index 739b432ac86f..fd710ebc72b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,8 +6,8 @@ pkgdesc="Hitch is a libev-based high performance SSL/TLS proxy."
arch=('x86_64' 'i686')
url="https://hitch-tls.org/"
license=('GPL')
-depends=('libev' 'openssl' 'python-docutils')
-makedepends=('git' 'lsof')
+depends=('libev' 'openssl')
+makedepends=('git' 'lsof' 'python-docutils')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=(
@@ -34,7 +34,7 @@ build() {
--prefix=/usr \
--sbindir=/usr/bin \
--enable-sessioncache
- make
+ make CFLAGS=-Wno-error=discarded-qualifiers
}
check() {