summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD31
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..31c55bb6d4db
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = hodlr
+ pkgdesc = A fast, accurate direct solver and determinant computation for dense linear systems
+ pkgver = r131.c69cf44
+ pkgrel = 1
+ url = https://github.com/sivaramambikasaran/HODLR
+ arch = any
+ license = MPL2
+ makedepends = cmake
+ depends = eigen
+ source = HODLR::git+https://github.com/sivaramambikasaran/HODLR.git
+ md5sums = SKIP
+
+pkgname = hodlr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..28825870ca05
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+pkgname=hodlr
+pkgver=r131.c69cf44
+pkgrel=1
+pkgdesc="A fast, accurate direct solver and determinant computation for dense linear systems"
+license=('MPL2')
+arch=('any')
+url="https://github.com/sivaramambikasaran/HODLR"
+depends=('eigen')
+makedepends=('cmake')
+source=("HODLR::git+https://github.com/sivaramambikasaran/HODLR.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd HODLR
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd HODLR
+ sed -i "s|\-Werror||g" CMakeLists.txt
+}
+
+build() {
+ cd HODLR
+ cmake -DCMAKE_INSTALL_PREFIX=/usr
+}
+
+package() {
+ cd HODLR
+ make DESTDIR="$pkgdir" install
+}