summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7fdb4efebd2c..f88519ae0012 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = hop
pkgdesc = Software Development Kit for the Web
pkgver = 3.1.0
- pkgrel = 5
+ pkgrel = 6
epoch = 1
url = http://hop.inria.fr
install = hop.install
@@ -9,7 +9,7 @@ pkgbase = hop
license = GPL
license = LGPL
makedepends = git
- depends = bigloo
+ depends = bigloo=4.3f
depends = gmp
depends = libunistring
depends = libuv
diff --git a/PKGBUILD b/PKGBUILD
index e814c83c6a15..ccc1843c9ab4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,14 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=hop
+_biglooversion=4.3f
epoch=1
pkgver=3.1.0
-pkgrel=5
+pkgrel=6
pkgdesc="Software Development Kit for the Web"
arch=('x86_64')
license=('GPL' 'LGPL')
-depends=('bigloo' 'gmp' 'libunistring' 'libuv' 'avahi' 'sqlite')
+depends=("bigloo=${_biglooversion}" 'gmp' 'libunistring' 'libuv' 'avahi' 'sqlite')
makedepends=('git')
conflicts=('hop')
provides=('hop')
@@ -23,7 +24,7 @@ build() {
cd $pkgname
./configure --prefix=/usr --etcdir=/etc/hop --mandir=/usr/share/man \
--disable-ssl --bigloobindir=/usr/bin --link=dynamic \
- --bigloolibdir=/usr/lib/bigloo/4.3f
+ --bigloolibdir=/usr/lib/bigloo/${_biglooversion}
sed -i 's/, -static-all-bigloo//' share/Makefile
LD_LIBRARY_PATH="$PWD/lib/hop/3.1.0/" make
}