summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
2 files changed, 10 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 65ac3a585fb1..2b024d89fb14 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,14 @@
pkgbase = horcrux-git
pkgdesc = Split your file into encrypted fragments so that you don't need to remember a passcode
pkgver = 0.3.r16.g6575949
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/jesseduffield/horcrux
arch = x86_64
license = MIT
makedepends = go
+ optdepends = horcrux-ui: graphical user interface
+ provides = horcrux
+ conflicts = horcrux-bin
options = !strip
source = git+https://github.com/jesseduffield/horcrux
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index e5c207061ec2..a06246697651 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,15 @@
pkgname="horcrux-git"
pkgver=0.3.r16.g6575949
-pkgrel=1
+pkgrel=2
pkgdesc="Split your file into encrypted fragments so that you don't need to remember a passcode"
arch=("x86_64")
url="https://github.com/jesseduffield/horcrux"
license=("MIT")
+provides=("horcrux")
+conflicts=("horcrux-bin")
makedepends=("go")
+optdepends=("horcrux-ui: graphical user interface")
source=("git+$url")
sha256sums=("SKIP")
options=("!strip")
@@ -29,6 +32,6 @@ build(){
package(){
cd "horcrux"
- install -D -m 0755 "horcrux" "$pkgdir/usr/bin/horcrux"
- install -D -m 0644 "LICENSE" "$pkgdir/usr/share/licenses/horcrux/LICENSE"
+ install -D -m 755 "horcrux" "$pkgdir/usr/bin/horcrux"
+ install -D -m 644 "LICENSE" "$pkgdir/usr/share/licenses/horcrux/LICENSE"
}