summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD42
-rw-r--r--horcrux.desktop7
-rw-r--r--horcrux.pngbin0 -> 7970 bytes
4 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..61153d912401
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = horcrux-ui-git
+ pkgdesc = GUI for horcrux
+ pkgver = 0.1.r12.gd35f41a
+ pkgrel = 1
+ url = https://github.com/jesseduffield/horcrux-ui
+ arch = x86_64
+ license = MIT
+ makedepends = go
+ depends = horcrux
+ provides = horcrux-ui
+ options = !strip
+ source = git+https://github.com/jesseduffield/horcrux-ui
+ source = horcrux.desktop
+ source = horcrux.png
+ sha256sums = SKIP
+ sha256sums = c451a7bf1a01a6f1fa120334f058aaf3b45109e9f7ad60175c13785eb39e186f
+ sha256sums = fba920923cb8e5a778723ba5b3b4615ccfaef7cd1f49fa080da44e2aff3c7b91
+
+pkgname = horcrux-ui-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3e65dd7bfca4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: AlphaJack <alphajack at tuta dot io>
+
+pkgname="horcrux-ui-git"
+pkgver=0.1.r12.gd35f41a
+pkgrel=1
+pkgdesc="GUI for horcrux"
+arch=("x86_64")
+url="https://github.com/jesseduffield/horcrux-ui"
+license=("MIT")
+provides=("horcrux-ui")
+depends=("horcrux")
+makedepends=("go")
+source=("git+$url"
+ "horcrux.desktop"
+ "horcrux.png")
+sha256sums=('SKIP'
+ 'c451a7bf1a01a6f1fa120334f058aaf3b45109e9f7ad60175c13785eb39e186f'
+ 'fba920923cb8e5a778723ba5b3b4615ccfaef7cd1f49fa080da44e2aff3c7b91')
+options=("!strip")
+
+pkgver(){
+ cd "horcrux-ui"
+ git describe --long --tags --abbrev=7 | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//g'
+}
+
+build(){
+ cd "horcrux-ui"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ go build -o horcrux-ui .
+}
+
+package(){
+ cd "horcrux-ui"
+ install -D -m 755 "horcrux-ui" "$pkgdir/usr/bin/horcrux-ui"
+ install -D -m 644 "LICENSE" "$pkgdir/usr/share/licenses/horcrux-ui/LICENSE"
+ install -D -m 644 "$srcdir/horcrux.png" "$pkgdir/usr/share/pixmaps/horcrux.png"
+ install -D -m 644 "$srcdir/horcrux.desktop" "$pkgdir/usr/share/applications/horcrux.desktop"
+}
diff --git a/horcrux.desktop b/horcrux.desktop
new file mode 100644
index 000000000000..df0ecb96f13c
--- /dev/null
+++ b/horcrux.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Name=Horcrux
+Comment=Split your file into encrypted fragments so that you don't need to remember a passcode
+Exec=horcrux-ui
+Icon=horcrux
+Type=Application
+Categories=Utility
diff --git a/horcrux.png b/horcrux.png
new file mode 100644
index 000000000000..22e09e7b1523
--- /dev/null
+++ b/horcrux.png
Binary files differ