summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-x[-rw-r--r--].SRCINFO5
-rwxr-xr-x[-rw-r--r--].gitignore0
-rwxr-xr-x[-rw-r--r--]PKGBUILD21
3 files changed, 10 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 31d3e48446c6..7551e896150f 100644..100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = hourglass-git
pkgdesc = A simple clock application that provides stopwatches, alarms, and timers designed for Pantheon Shell
- pkgver = latest
+ pkgver = r73.f7cd686
pkgrel = 1
url = https://github.com/sgpthomas/hourglass
arch = i686
arch = x86_64
license = GPL3
- makedepends = cmake
makedepends = git
+ makedepends = meson
makedepends = vala
depends = gtk3
depends = granite
@@ -15,6 +15,7 @@ pkgbase = hourglass-git
depends = libcanberra
depends = libgee
depends = libnotify
+ optdepends =
provides = hourglass
conflicts = hourglass
source = git+https://github.com/sgpthomas/hourglass.git
diff --git a/.gitignore b/.gitignore
index b25c15b81fae..b25c15b81fae 100644..100755
--- a/.gitignore
+++ b/.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index d41c874e8b89..ef2e92c91e0c 100644..100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_gitname=hourglass
_author=sgpthomas
pkgname=("${_gitname}-git")
-pkgver=latest
+pkgver=r73.f7cd686
pkgrel=1
pkgdesc="A simple clock application that provides stopwatches, alarms, and timers designed for Pantheon Shell"
arch=('i686' 'x86_64')
@@ -12,7 +12,7 @@ url="https://github.com/${_author}/${_gitname}"
license=('GPL3')
depends=('gtk3' 'granite' 'glib2' 'libcanberra' 'libgee' 'libnotify')
optdepends=('')
-makedepends=('cmake' 'git' 'vala')
+makedepends=('git' 'meson' 'vala')
provides=("${_gitname}")
conflicts=("${_gitname}")
source=("git+${url}.git")
@@ -26,21 +26,14 @@ pkgver() {
)
}
-prepare() {
- cd "${_gitname}"
- install -d build
-}
-
build() {
- cd "${_gitname}/build"
- cmake .. \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr
- make
+ cd "${_gitname}/"
+ meson . _build --prefix=/usr
+ ninja -C _build
}
package() {
- cd "${_gitname}/build"
- make DESTDIR="${pkgdir}" install
+ cd "${_gitname}/"
+ DESTDIR="${pkgdir}" ninja -C _build install
}