summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD32
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..66bffe814912
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = htmltui
+ pkgdesc = A terminal UI utility to view HTML
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = https://git.dtluna.net/dtluna/htmltui
+ arch = any
+ license = custom:WTFPL
+ makedepends = go
+ conflicts = htmltui-bin
+ source = https://git.dtluna.net/dtluna/htmltui/archive/v1.1.0.tar.gz
+ sha256sums = ef795e477d9e07bcc16e72488045698e79aa99bfff9edb3efd0b51de775ee8c9
+
+pkgname = htmltui
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..31d27563afeb
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a92f218a8b67
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: dtluna <dtluna at waifu dot club>
+
+pkgname='htmltui'
+pkgver='1.1.0'
+pkgrel=1
+pkgdesc='A terminal UI utility to view HTML'
+url='https://git.dtluna.net/dtluna/htmltui'
+arch=('any')
+license=('custom:WTFPL')
+
+depends=()
+makedepends=('go')
+optdepends=()
+
+conflicts=('htmltui-bin')
+
+source=("${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('ef795e477d9e07bcc16e72488045698e79aa99bfff9edb3efd0b51de775ee8c9')
+
+build() {
+ cd $srcdir/$pkgname
+ go build -o $pkgname
+}
+
+package() {
+ # Bin
+ rm -f "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm755 "${srcdir}/${pkgname}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+
+ # License
+ install -Dm644 "${srcdir}/${pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}