summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD26
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9fbe1dfed85d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = httpshell
+ pkgdesc = An interactive shell for issuing HTTP commands to a web server or REST API
+ pkgver = 0.8.0
+ pkgrel = 2
+ url = https://github.com/chrislongo/HttpShell/
+ arch = any
+ license = MIT
+ makedepends = python2-distribute
+ depends = python2
+ depends = python2-pygments
+ depends = python2-httplib2
+ depends = python2-oauth2
+ provides = httpsh
+ source = http://github.com/downloads/chrislongo/HttpShell/httpshell-0.8.0.tar.gz
+ sha256sums = a639da2fd3f5b98e064df9a5ca9949f153cc948287075112b1c847c1a9bdda42
+
+pkgname = httpshell
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ea8a44a10a90
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# $Id$
+# Maintainer: Fabien Devaux <fdev 31 @ gmail dot com>
+# Contributor: Chris Longo <chris . longo @ gmail dot com>
+# NOTE: python-oauth seems lacking so it can use python3
+
+pkgname=httpshell
+provides=('httpsh')
+_uc_pkg=HttpShell
+_auth=chrislongo
+pkgver=0.8.0
+pkgrel=2
+pkgdesc="An interactive shell for issuing HTTP commands to a web server or REST API"
+arch=('any')
+url="https://github.com/$_auth/$_uc_pkg/"
+license=('MIT')
+depends=('python2' 'python2-pygments' 'python2-httplib2' 'python2-oauth2')
+makedepends=('python2-distribute')
+source=(http://github.com/downloads/$_auth/$_uc_pkg/${pkgname}-${pkgver}.tar.gz)
+sha256sums=('a639da2fd3f5b98e064df9a5ca9949f153cc948287075112b1c847c1a9bdda42')
+
+build() {
+ cd $_auth-$_uc_pkg-*
+ python2 setup.py build || exit 1
+ python2 setup.py install --root="${pkgdir}" --optimize=1 || exit 1
+}
+