summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD20
-rw-r--r--huggle-desktop.patch14
-rw-r--r--huggle-yaml.patch30
4 files changed, 33 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8e9f9f9aea40..d9f6508138da 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,21 @@
pkgbase = huggle
pkgdesc = Anti-vandalism tool for use on MediaWiki-based projects
- pkgver = 3.4.10
+ pkgver = 3.4.12
pkgrel = 1
url = https://en.wikipedia.org/wiki/Wikipedia:Huggle
arch = i686
arch = x86_64
license = GPL
makedepends = cmake
- makedepends = ninja
depends = qt5-multimedia
depends = qt5-webengine
depends = yaml-cpp
- source = https://github.com/huggle/huggle3-qt-lx/releases/download/3.4.10/huggle_3.4.10.tar.gz
- source = huggle-yaml.patch
+ conflicts = libircclient
+ source = https://github.com/huggle/huggle3-qt-lx/releases/download/3.4.12/huggle_3.4.12.tar.gz
source = huggle-extensions.patch
- sha256sums = 7dbf2c943f80eac551839535df68d1af4c19d52a026a9140a1b2fcf63f5a2249
- sha256sums = e66bb7ba73b72b08d478715d44baf096c87291e05997ad4786c1515b6574f2bb
- sha256sums = 823cbf583c00722bfe5ecd74a57ee7e3ef942ecb95a1704e65c226e7a2624497
+ source = huggle-desktop.patch
+ b2sums = 876040712fd59a2efc1f5cc20af1fc9583c9fe13213a03cdc7ca2d90da3880b88c531b112693414e595398d09af1875e73d2a828b5835227a41cb0c4df90ee37
+ b2sums = e37d338085329911277cabd58108a0be5114b2c3b0469d0e3ed4bfbabda02c85315698c1ce466cb3c9bb25adb4ba208f69a134b4eb9079a2f70b8a36815f077a
+ b2sums = 4fa21457d39061bbba01c2e5f5ac9d6d703b56103fac82e48cff09d94b5ca4fe9a912756dad2c7c90079e556814654730b0c18f97f93de11b25b32ac740367ff
pkgname = huggle
-
diff --git a/PKGBUILD b/PKGBUILD
index 8c32493157c2..601552073463 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,29 +2,31 @@
# Contributor: Samuel Damashek <samuel dot damashek at gmail dot com>
# Contributor: Alex Xu <alex_y_xu dot yahoo at ca>
pkgname=huggle
-pkgver=3.4.10
+pkgver=3.4.12
pkgrel=1
pkgdesc="Anti-vandalism tool for use on MediaWiki-based projects"
arch=('i686' 'x86_64')
url="https://en.wikipedia.org/wiki/Wikipedia:Huggle"
license=('GPL')
depends=('qt5-multimedia' 'qt5-webengine' 'yaml-cpp')
-makedepends=('cmake' 'ninja')
+makedepends=('cmake')
+conflicts=('libircclient') # A different, unrelated, libircclient
source=(
"https://github.com/huggle/huggle3-qt-lx/releases/download/${pkgver}/${pkgname}_${pkgver}.tar.gz"
- "huggle-yaml.patch"
"huggle-extensions.patch"
+ "huggle-desktop.patch"
)
-sha256sums=('7dbf2c943f80eac551839535df68d1af4c19d52a026a9140a1b2fcf63f5a2249'
- 'e66bb7ba73b72b08d478715d44baf096c87291e05997ad4786c1515b6574f2bb'
- '823cbf583c00722bfe5ecd74a57ee7e3ef942ecb95a1704e65c226e7a2624497')
+b2sums=('876040712fd59a2efc1f5cc20af1fc9583c9fe13213a03cdc7ca2d90da3880b88c531b112693414e595398d09af1875e73d2a828b5835227a41cb0c4df90ee37'
+ 'e37d338085329911277cabd58108a0be5114b2c3b0469d0e3ed4bfbabda02c85315698c1ce466cb3c9bb25adb4ba208f69a134b4eb9079a2f70b8a36815f077a'
+ '4fa21457d39061bbba01c2e5f5ac9d6d703b56103fac82e48cff09d94b5ca4fe9a912756dad2c7c90079e556814654730b0c18f97f93de11b25b32ac740367ff')
prepare() {
cd "${pkgname}_${pkgver}"
# Patch extension directory to /usr/lib/huggle/extensions (T251049)
patch --forward --strip=1 --input="../huggle-extensions.patch"
- # Backport dependency fix from master, remove in 3.4.11
- patch --forward --strip=1 --input="../huggle-yaml.patch"
+ # Fix icon in huggle.desktop
+ patch --forward --strip=1 --input="../huggle-desktop.patch"
+ echo "+archlinux.${pkgrel}" >> src/huggle_core/version.txt
}
build() {
@@ -46,4 +48,6 @@ build() {
package() {
make DESTDIR="$pkgdir/" -C build install
+
+ install -Dm644 "${pkgname}_${pkgver}/src/huggle_res/Resources/huggle3_newlogo.png" "$pkgdir/usr/share/pixmaps/huggle.png"
}
diff --git a/huggle-desktop.patch b/huggle-desktop.patch
new file mode 100644
index 000000000000..88c93b2da860
--- /dev/null
+++ b/huggle-desktop.patch
@@ -0,0 +1,14 @@
+diff --git a/src/build/huggle.desktop b/src/build/huggle.desktop
+index 51d4b72c..3413a79a 100644
+--- a/src/build/huggle.desktop
++++ b/src/build/huggle.desktop
+@@ -3,7 +3,7 @@ Name=Huggle
+ GenericName=Huggle
+ Comment=Huggle is an anti-vandalism tool for use on Wikipedia and related projects
+ Exec=huggle
+-Icon=/snap/huggle/current/meta/gui/icon.png
++Icon=huggle
+ StartupNotify=true
+ Terminal=false
+ Type=Application
+
diff --git a/huggle-yaml.patch b/huggle-yaml.patch
deleted file mode 100644
index 1eba4ed19bf9..000000000000
--- a/huggle-yaml.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
-index a37976e3..b7530e8f 100644
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -63,12 +63,19 @@ add_subdirectory(3rd/libirc/libirc libirc)
- add_subdirectory(3rd/libirc/libircclient libircclient)
-
- # YAML
--option(YAML_CPP_BUILD_TOOLS "Disable tests" OFF)
--option(YAML_CPP_BUILD_TESTS "Enable testing" OFF)
--option(YAML_CPP_BUILD_TOOLS "Enable parse tools" OFF)
--option(BUILD_SHARED_LIBS "Build as shared" ON)
--include_directories("3rd/yaml-cpp/include/")
--add_subdirectory(3rd/yaml-cpp)
-+find_package(YAML-CPP 0.6.3 QUIET)
-+if (YAML-CPP_FOUND)
-+ message(STATUS "Using system yaml-cpp")
-+ include_directories(YAML_CPP_INCLUDE_DIR)
-+else()
-+ option(YAML_CPP_BUILD_TOOLS "Disable tests" OFF)
-+ option(YAML_CPP_BUILD_TESTS "Enable testing" OFF)
-+ option(YAML_CPP_BUILD_TOOLS "Enable parse tools" OFF)
-+ option(BUILD_SHARED_LIBS "Build as shared" ON)
-+ include_directories("3rd/yaml-cpp/include/")
-+ add_subdirectory(3rd/yaml-cpp)
-+endif()
-+
- if (HUGGLE_EXT)
- if(NOT MINGW AND WIN32)
- set(CMAKE_RUNTIME_OUTPUT_DIRECTORY_RELEASE ${CMAKE_CURRENT_BINARY_DIR}/Release/extensions)