summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD17
2 files changed, 14 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 70d430fa6f33..44463beb149e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Feb 12 16:40:42 UTC 2016
+# Tue Feb 16 18:06:45 UTC 2016
pkgbase = huggle
pkgdesc = diff browser intended for dealing with vandalism and other unconstructive edits on Wikimedia projects
- pkgver = 3.1.19
- pkgrel = 2
+ pkgver = 3.1.20.g7f116e7
+ pkgrel = 1
url = https://en.wikipedia.org/wiki/Wikipedia:Huggle
arch = i686
arch = x86_64
@@ -13,8 +13,8 @@ pkgbase = huggle
makedepends = unzip
depends = qt5-base
depends = qt5-webkit
- source = https://github.com/huggle/huggle3-qt-lx/archive/3.1.19.tar.gz
- md5sums = c938cdcde4b6e7b928c6670371d368c9
+ source = https://github.com/huggle/huggle3-qt-lx/archive/7f116e7af68430cfbe0222809c7aaa5f1d3b59c9.tar.gz
+ md5sums = ebf49ef1004d2d1448710cbd0db6d460
pkgname = huggle
diff --git a/PKGBUILD b/PKGBUILD
index 03c70b83e70e..38a7df37d9b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: Samuel Damashek <samuel dot damashek at gmail dot com>
pkgname=huggle
-pkgver=3.1.19
-pkgrel=2
+_gitver=7f116e7af68430cfbe0222809c7aaa5f1d3b59c9
+pkgver=3.1.20.g${_gitver:0:7}
+pkgrel=1
pkgdesc="diff browser intended for dealing with vandalism and other unconstructive edits on Wikimedia projects"
arch=('i686' 'x86_64')
url="https://en.wikipedia.org/wiki/Wikipedia:Huggle"
@@ -9,19 +10,19 @@ license=('GPL')
depends=('qt5-base' 'qt5-webkit')
makedepends=('cmake' 'unzip')
groups=('base-devel')
-source=("https://github.com/huggle/huggle3-qt-lx/archive/${pkgver}.tar.gz")
-md5sums=('c938cdcde4b6e7b928c6670371d368c9')
+source=("https://github.com/huggle/huggle3-qt-lx/archive/${_gitver}.tar.gz")
+md5sums=('ebf49ef1004d2d1448710cbd0db6d460')
+
prepare() {
- cd "$srcdir/huggle3-qt-lx-$pkgver"
+ cd "$srcdir/huggle3-qt-lx-${_gitver}/huggle"
pushd libs
-
unzip libirc.zip
}
build() {
- cd "$srcdir/huggle3-qt-lx-$pkgver/huggle"
+ cd "$srcdir/huggle3-qt-lx-${_gitver}/huggle"
cmake . -DCMAKE_INSTALL_PREFIX=/usr
@@ -29,6 +30,6 @@ build() {
}
package() {
- cd "$srcdir/huggle3-qt-lx-$pkgver/huggle"
+ cd "$srcdir/huggle3-qt-lx-${_gitver}/huggle"
make DESTDIR=$pkgdir install
}