summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
-rw-r--r--install.sh78
-rwxr-xr-xtest.sh1
4 files changed, 10 insertions, 86 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0f60c9fa57dc..34fb237e23c5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,13 @@
pkgbase = hydra-launcher
pkgdesc = No bullshit, just play
pkgver = 1.1.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/hydralauncher/hydra
arch = x86_64
license = MIT
provides = hydra-launcher
+ options = debug
+ options = !strip
source_x86_64 = https://github.com/hydralauncher/hydra/releases/download/v1.1.0/hydra-launcher_1.1.0_amd64.deb
sha256sums_x86_64 = 66ef041728020388b84ddf10e34207377d370101e2244e613fac1bbb65e0272c
diff --git a/PKGBUILD b/PKGBUILD
index a2dc1adb0535..4e5bcbacc2f2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,13 @@
pkgname=hydra-launcher
_pkgname=hydra-launcher
pkgver=1.1.0
-pkgrel=2
+pkgrel=3
pkgdesc="No bullshit, just play"
arch=('x86_64')
url="https://github.com/hydralauncher/hydra"
license=('MIT')
provides=('hydra-launcher')
+options=(debug !strip)
source=()
@@ -16,10 +17,10 @@ source_x86_64=("https://github.com/hydralauncher/hydra/releases/download/v${pkgv
sha256sums_x86_64=('66ef041728020388b84ddf10e34207377d370101e2244e613fac1bbb65e0272c')
package() {
- cd ${srcdir}
-
- tar -xf data.tar.zst -C ${pkgdir} --exclude='./control'
- chmod go-w "${pkgdir}"/usr "${pkgdir}"/usr/bin
- chmod -R go-w "${pkgdir}"/usr/share
+ tar -xvf 'data.tar.zst' -C "${pkgdir}"
+ install -dv "${pkgdir}/usr/bin"
+ ln -sfv "/usr/lib/hydra-launcher/Hydra" -t "${pkgdir}/usr/bin"
+ install -Dvm644 "${pkgdir}/usr/lib/hydra-launcher/"LICENSES.chromium.html \
+ -t "${pkgdir}/usr/share/licenses/hydra-launcher"
}
diff --git a/install.sh b/install.sh
deleted file mode 100644
index ddc8827df6df..000000000000
--- a/install.sh
+++ /dev/null
@@ -1,78 +0,0 @@
-basename=slk-eng
-pkgname=dict-freedict-$basename
-dictd_conf=/etc/dict/dictd.conf
-datadir=/usr/share/dictd
-conf="database $basename {
- data $datadir/$basename.dict.dz
- index $datadir/$basename.index
-}"
-
-post_install()
-{
- echo
- if pacman -Qq dictd > /dev/null 2>&1
- then
- if grep -q "^database *$basename" "$dictd_conf"
- then
- echo "$pkgname already configured in $dictd_conf"
- else
- echo "Adding configuration for $pkgname to $dictd_conf"
- echo "$conf" >> "$dictd_conf"
- fi
-
- if systemctl -q is-active dictd.service
- then
- echo "Restarting dictd service in order to" \
- "use the new dictionary database"
- systemctl restart dictd.service
- else
- echo "Starting dictd service in order to" \
- "use the new dictionary database"
- systemctl start dictd.service
- fi
- else
- echo "dictd does not appear to be installed."
- echo "In order to use this database you should either" \
- "install dictd or alternatively" \
- "another dict server and configure it on your own."
- fi
- echo
-}
-
-post_upgrade()
-{
- if pacman -Qq dictd > /dev/null 2>&1 && \
- systemctl -q is-active dictd.service
- then
- echo -e "\nRestarting dictd service in order to" \
- "use the updated dictionary database"
- systemctl restart dictd.service
- fi
-}
-
-post_remove()
-{
- if pacman -Qq dictd > /dev/null 2>&1
- then
- current_conf="$(grep -A 3 "^database *$basename" "$dictd_conf")"
- if test -n "$current_conf"
- then
- echo
- if test "$current_conf" = "$conf"
- then
- echo "Removing configuration for $pkgname from $dictd_conf"
- sed -i "/database $basename {/,/}/d" "$dictd_conf"
- else
- echo "User created / modified configuration" \
- "for $pkgname in $dictd_conf is left untouched."
- fi
- fi
-
- if systemctl -q is-active dictd.service
- then
- echo "Restarting dictd service in order to" \
- "stop using the removed dictionary database"
- systemctl restart dictd.service
- fi
- fi
-}
diff --git a/test.sh b/test.sh
deleted file mode 100755
index 36f0670f54d0..000000000000
--- a/test.sh
+++ /dev/null
@@ -1 +0,0 @@
-echo 'test'