summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.AURINFO16
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD35
-rw-r--r--hydroxygen-chtype4
-rw-r--r--hydroxygen-iconset.install4
5 files changed, 77 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..3aa3d2d3faf3
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,16 @@
+pkgbase = hydroxygen-iconset
+ pkgdesc = GTK+ port of the KDE4 Oxygen icon theme
+ pkgver = 20090119
+ pkgrel = 2.1
+ url = http://deviantdark.deviantart.com/art/hydroxygen-iconset-100826865
+ install = hydroxygen-iconset.install
+ arch = i686
+ arch = x86_64
+ license = custom:cc-gnu_gpl
+ makedepends = findutils
+ depends = gtk2
+ source = http://fc04.deviantart.com/fs40/f/2009/019/8/7/hydroxygen_iconset_by_deviantdark.zip
+ source = hydroxygen-chtype
+
+pkgname = hydroxygen-iconset
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4de027db0449
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = hydroxygen-iconset
+ pkgdesc = GTK+ port of the KDE4 Oxygen icon theme
+ pkgver = 20090119
+ pkgrel = 2.1
+ url = http://deviantdark.deviantart.com/art/hydroxygen-iconset-100826865
+ install = hydroxygen-iconset.install
+ arch = i686
+ arch = x86_64
+ license = custom:cc-gnu_gpl
+ makedepends = findutils
+ depends = gtk2
+ source = http://fc04.deviantart.com/fs40/f/2009/019/8/7/hydroxygen_iconset_by_deviantdark.zip
+ source = hydroxygen-chtype
+ sha256sums = ff6e22c842c4f8a3f9a38dc6d0f78cfde116e22d8bee606db072b0c03d4389e5
+ sha256sums = d99f13f554b9b87f2c618247af4413a9276e658e77ebc242bc2b1fbcaaaca4de
+
+pkgname = hydroxygen-iconset
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a73c3c611653
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Alireza Savand <alireza.savand@gmail.com>
+# Contributors:
+# * Devin Cofer <ranguvar{AT]archlinux[DOT}us>
+# * William Díaz <wdiaz [at] archlinux [dot] us>
+# * Simone Pignatti <simo91.linux@gmail.com>
+
+pkgname=hydroxygen-iconset
+pkgver=20090119
+pkgrel=2.1
+pkgdesc="GTK+ port of the KDE4 Oxygen icon theme"
+arch=('i686' 'x86_64')
+url="http://deviantdark.deviantart.com/art/hydroxygen-iconset-100826865"
+license=("custom:cc-gnu_gpl")
+
+makedepends=('findutils')
+depends=('gtk2')
+
+source=("http://fc04.deviantart.com/fs40/f/2009/019/8/7/hydroxygen_iconset_by_deviantdark.zip"
+ 'hydroxygen-chtype')
+sha256sums=('ff6e22c842c4f8a3f9a38dc6d0f78cfde116e22d8bee606db072b0c03d4389e5'
+ 'd99f13f554b9b87f2c618247af4413a9276e658e77ebc242bc2b1fbcaaaca4de')
+install="$pkgname.install"
+
+package() {
+ cd "$srcdir/iconset"
+
+ tar xf hydroxygen_iconset.tar.bz2
+ find hydroxygen -type d -print0 | xargs -0 chmod 0775
+ find hydroxygen -type f -print0 | xargs -0 chmod 0664
+ install -Dm755 "$srcdir/hydroxygen-chtype" "$pkgdir/usr/bin/hydroxygen-chtype"
+
+ install -Dm644 "hydroxygen/COPYING" "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+ mkdir -p "$pkgdir/usr/share/icons/"
+ mv hydroxygen/ "$pkgdir/usr/share/icons/"
+}
diff --git a/hydroxygen-chtype b/hydroxygen-chtype
new file mode 100644
index 000000000000..d39453ddbe8a
--- /dev/null
+++ b/hydroxygen-chtype
@@ -0,0 +1,4 @@
+#!/bin/bash
+
+cd /usr/share/icons/hydroxygen/
+sudo sh change-type.sh $@
diff --git a/hydroxygen-iconset.install b/hydroxygen-iconset.install
new file mode 100644
index 000000000000..bb325137f664
--- /dev/null
+++ b/hydroxygen-iconset.install
@@ -0,0 +1,4 @@
+post_install() {
+ echo -e "\e[1;32m==> \e[0m Use 'sudo hydroxygen-chtype icon_name' to change icons."
+ echo -e "\e[1;32m==> \e[0m Please read the instructions in the /usr/share/icons/hydroxygen/ directory."
+}