summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--paths-in-opt.patch20
3 files changed, 16 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3673f7ff460a..33839bbf28b1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hydrus
pkgdesc = Danbooru-like image tagging and searching system for the desktop
- pkgver = 497
+ pkgver = 498
pkgrel = 1
url = http://hydrusnetwork.github.io/hydrus/
install = hydrus.install
@@ -38,13 +38,13 @@ pkgbase = hydrus
conflicts = hydrus-docs
conflicts = hydrus-sources
options = !strip
- source = hydrus::git+https://github.com/hydrusnetwork/hydrus.git#commit=dabdbe2861f2e9b68d9df4f3ca52a9c37b259bd5
+ source = hydrus::git+https://github.com/hydrusnetwork/hydrus.git#commit=aa78ecaafc9285ca6bb1b439af4866d4f454cf79
source = paths-in-opt.patch
source = hydrus-client
source = hydrus-server
source = hydrus.desktop
sha256sums = SKIP
- sha256sums = 5ada0e317adf6793733fb1f9b433eb95a4e985de70d068a40a72bd19df097cbc
+ sha256sums = 0607fdbcd9d4e7115c0cc3b533c68a72b45a631a2d15f838e05cc15654a26345
sha256sums = d2cb826ce0dd1892ab95fc3b14dbe6bd312210f653d0aea31938eeb7e361fdc5
sha256sums = 463841cc16059b516cc327cfbc30d3383e2236b085ba2d503e82f5be39444806
sha256sums = 9b8c2603a8040ae80152ff9a718ad3e8803fdc3029a939e3c0e932ea35ded923
diff --git a/PKGBUILD b/PKGBUILD
index 04a994b331a1..7a2da6438829 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ DOC_DIRS=(opt/hydrus/help)
pkgname=hydrus
_pkgname=hydrus
-pkgver=497
+pkgver=498
pkgrel=1
pkgdesc="Danbooru-like image tagging and searching system for the desktop"
arch=(any)
@@ -24,13 +24,13 @@ optdepends=('ffmpeg: show duration and other information on video thumbnails'
'python-cloudscraper: bypass cloudflare "checking your browser" challenges'
'python-pyqt5-chart: display bandwidth usage charts'
'python-pyopenssl: to generate certificates for accessing client API and server via HTTPS')
-source=("${_pkgname}::git+https://github.com/hydrusnetwork/${_pkgname}.git#commit=dabdbe2861f2e9b68d9df4f3ca52a9c37b259bd5"
+source=("${_pkgname}::git+https://github.com/hydrusnetwork/${_pkgname}.git#commit=aa78ecaafc9285ca6bb1b439af4866d4f454cf79"
paths-in-opt.patch
hydrus-client
hydrus-server
hydrus.desktop)
sha256sums=('SKIP'
- '5ada0e317adf6793733fb1f9b433eb95a4e985de70d068a40a72bd19df097cbc'
+ '0607fdbcd9d4e7115c0cc3b533c68a72b45a631a2d15f838e05cc15654a26345'
'd2cb826ce0dd1892ab95fc3b14dbe6bd312210f653d0aea31938eeb7e361fdc5'
'463841cc16059b516cc327cfbc30d3383e2236b085ba2d503e82f5be39444806'
'9b8c2603a8040ae80152ff9a718ad3e8803fdc3029a939e3c0e932ea35ded923')
diff --git a/paths-in-opt.patch b/paths-in-opt.patch
index f8fd5d00b701..ab18ff928b54 100644
--- a/paths-in-opt.patch
+++ b/paths-in-opt.patch
@@ -1,18 +1,18 @@
diff --git a/hydrus/client/gui/ClientGUI.py b/hydrus/client/gui/ClientGUI.py
-index 944af47..8e9bcce 100644
+index 4b5b1d84..687142fe 100644
--- a/hydrus/client/gui/ClientGUI.py
+++ b/hydrus/client/gui/ClientGUI.py
-@@ -5969,7 +5969,7 @@ class FrameGUI( ClientGUITopLevelWindows.MainFrameThatResizes ):
- python_executable = python_executable.replace( 'pythonw', 'python' )
+@@ -6102,7 +6102,7 @@ class FrameGUI( ClientGUITopLevelWindows.MainFrameThatResizes, CAC.ApplicationCo
+ python_executable = python_executable.replace( 'pythonw', 'python' )
+
+
+- server_script_path = os.path.join( HC.BASE_DIR, 'server.py' )
++ server_script_path = '/opt/hydrus/server.py'
+
+ cmd = [ python_executable, server_script_path, db_param ]
-
-- server_script_path = os.path.join( HC.BASE_DIR, 'server.py' )
-+ server_script_path = '/opt/hydrus/server.py'
-
- cmd = [ python_executable, server_script_path, db_param ]
-
diff --git a/hydrus/core/HydrusConstants.py b/hydrus/core/HydrusConstants.py
-index 03453fe..7a53939 100644
+index 17d995c9..785922d2 100644
--- a/hydrus/core/HydrusConstants.py
+++ b/hydrus/core/HydrusConstants.py
@@ -7,34 +7,9 @@ import yaml