summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--paths-in-opt.patch11
3 files changed, 12 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 52f9e88a1c5b..b483ec61b581 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun May 29 22:26:12 UTC 2016
+# Thu Jun 2 00:22:45 UTC 2016
pkgbase = hydrus
pkgdesc = Danbooru-like image tagging and searching system for the desktop
- pkgver = 207
+ pkgver = 208
pkgrel = 1
url = http://hydrusnetwork.github.io/hydrus/
arch = any
@@ -32,13 +32,13 @@ pkgbase = hydrus
optdepends = desktop-file-utils: to add Hydrus to your desktop environment menus
options = !strip
options = docs
- source = hydrus::git+https://github.com/hydrusnetwork/hydrus.git#commit=236d79aa0af6b8160127e7f3388ec278ffb42632
+ source = hydrus::git+https://github.com/hydrusnetwork/hydrus.git#commit=bf0c4e2d8063a12f84c0e09e9dc9377d29e80527
source = paths-in-opt.patch
source = hydrus-client
source = hydrus-server
source = hydrus.desktop
sha256sums = SKIP
- sha256sums = 3d340ee352a8c1959050d2f1f474d6a80d06e199c336bc322250b40e746ddd7e
+ sha256sums = d8599ad83e05399f8718c836580d7396cd2ca4ee0531e42b146f4fd9929c203c
sha256sums = b2bf66b1068969e9598742d5c128cb04fd609512b0cff0ad5e25ecb6cdd35678
sha256sums = 5fd3eb69bb5f9a0b88d7c1b25abdee42aa2b2fc5e1690635f60ed1f47848c46b
sha256sums = 9ba3942ac1a37f6b39c98ae6592573402bf08d8376f64554d0696c0fed6fd0e2
diff --git a/PKGBUILD b/PKGBUILD
index 901c10117532..76183d0dc1d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ DOC_DIRS=(opt/hydrus/help)
pkgbase=hydrus
pkgname=(hydrus hydrus-docs hydrus-sources)
-pkgver=207
+pkgver=208
pkgrel=1
pkgdesc="Danbooru-like image tagging and searching system for the desktop"
arch=(any)
@@ -18,13 +18,13 @@ makedepends=(git)
optdepends=('ffmpeg: show duration and other information on video thumbnails'
'miniupnpc: automatic port forwarding'
'desktop-file-utils: to add Hydrus to your desktop environment menus')
-source=("${pkgbase}::git+https://github.com/hydrusnetwork/${pkgbase}.git#commit=236d79aa0af6b8160127e7f3388ec278ffb42632"
+source=("${pkgbase}::git+https://github.com/hydrusnetwork/${pkgbase}.git#commit=bf0c4e2d8063a12f84c0e09e9dc9377d29e80527"
paths-in-opt.patch
hydrus-client
hydrus-server
hydrus.desktop)
sha256sums=('SKIP'
- '3d340ee352a8c1959050d2f1f474d6a80d06e199c336bc322250b40e746ddd7e'
+ 'd8599ad83e05399f8718c836580d7396cd2ca4ee0531e42b146f4fd9929c203c'
'b2bf66b1068969e9598742d5c128cb04fd609512b0cff0ad5e25ecb6cdd35678'
'5fd3eb69bb5f9a0b88d7c1b25abdee42aa2b2fc5e1690635f60ed1f47848c46b'
'9ba3942ac1a37f6b39c98ae6592573402bf08d8376f64554d0696c0fed6fd0e2')
diff --git a/paths-in-opt.patch b/paths-in-opt.patch
index 38bd41d04e91..ce3b4f60d509 100644
--- a/paths-in-opt.patch
+++ b/paths-in-opt.patch
@@ -1,5 +1,5 @@
diff --git a/include/ClientGUI.py b/include/ClientGUI.py
-index 99d0f78..a201ea1 100755
+index 1ca58f2..3394ced 100755
--- a/include/ClientGUI.py
+++ b/include/ClientGUI.py
@@ -156,7 +156,7 @@ class FrameGUI( ClientGUICommon.FrameThatResizes ):
@@ -21,10 +21,10 @@ index 99d0f78..a201ea1 100755
time_waited = 0
diff --git a/include/HydrusConstants.py b/include/HydrusConstants.py
-index a0a77fb..2a74aa2 100755
+index 8627244..50dda3e 100755
--- a/include/HydrusConstants.py
+++ b/include/HydrusConstants.py
-@@ -3,24 +3,9 @@ import sys
+@@ -3,36 +3,25 @@ import sys
# dirs
@@ -50,9 +50,8 @@ index a0a77fb..2a74aa2 100755
+
+BIN_DIR = "/opt/hydrus/bin"
DB_DIR = os.path.join( BASE_DIR, 'db' )
- CLIENT_ARCHIVES_DIR = os.path.join( DB_DIR, 'client_archives' )
- CLIENT_FILES_DIR = os.path.join( DB_DIR, 'client_files' )
-@@ -29,12 +14,16 @@ CLIENT_THUMBNAILS_DIR = os.path.join( DB_DIR, 'client_thumbnails' )
+ SERVER_FILES_DIR = os.path.join( DB_DIR, 'server_files' )
+ CLIENT_THUMBNAILS_DIR = os.path.join( DB_DIR, 'client_thumbnails' )
SERVER_THUMBNAILS_DIR = os.path.join( DB_DIR, 'server_thumbnails' )
CLIENT_UPDATES_DIR = os.path.join( DB_DIR, 'client_updates' )
SERVER_UPDATES_DIR = os.path.join( DB_DIR, 'server_updates' )