summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
-rw-r--r--paths-in-opt.patch8
-rw-r--r--pil-tostring-is-gone.patch26
4 files changed, 8 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3d99554a42c1..7f8355fd59d2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -28,17 +28,15 @@ pkgbase = hydrus
optdepends = miniupnpc: automatic port forwarding
optdepends = desktop-file-utils: to add Hydrus to your desktop environment menus
options = !strip
- source = hydrus::git+https://github.com/hydrusnetwork/hydrus.git#commit=5ffe0f73ca6eae5fcbd53828b3fb401250423690
+ source = hydrus::git+https://github.com/hydrusnetwork/hydrus.git#commit=cfb25c7739e16f2385c9b6adf547163a7712d3cf
source = paths-in-opt.patch
source = running-the-server.patch
- source = pil-tostring-is-gone.patch
source = hydrus-client
source = hydrus-server
source = hydrus.desktop
sha256sums = SKIP
- sha256sums = d316105494d07fa0a46483089e707ccd24f157d7b72b6925ae6e1b47085940a5
+ sha256sums = ecae339ef65c15ceb8151a05b97eaa3d2090147d24f4d82dc673c900ed65bcd9
sha256sums = 8b47161065328dab0c9de293a8a2b4343e5c5fab464eb301f028758fb2666c6d
- sha256sums = 69fa2bc03ed4f1a4aee2943ea8144cdf9573f5f8b56bb7f50278d5971f27311e
sha256sums = b2bf66b1068969e9598742d5c128cb04fd609512b0cff0ad5e25ecb6cdd35678
sha256sums = 5fd3eb69bb5f9a0b88d7c1b25abdee42aa2b2fc5e1690635f60ed1f47848c46b
sha256sums = 9ba3942ac1a37f6b39c98ae6592573402bf08d8376f64554d0696c0fed6fd0e2
diff --git a/PKGBUILD b/PKGBUILD
index c7c59c893505..deec4e5dbe38 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -26,17 +26,15 @@ makedepends=(git)
optdepends=('ffmpeg: show duration and other information on video thumbnails'
'miniupnpc: automatic port forwarding'
'desktop-file-utils: to add Hydrus to your desktop environment menus')
-source=("${pkgname}::git+https://github.com/hydrusnetwork/${pkgname}.git#commit=5ffe0f73ca6eae5fcbd53828b3fb401250423690"
+source=("${pkgname}::git+https://github.com/hydrusnetwork/${pkgname}.git#commit=cfb25c7739e16f2385c9b6adf547163a7712d3cf"
paths-in-opt.patch
running-the-server.patch
- pil-tostring-is-gone.patch
hydrus-client
hydrus-server
hydrus.desktop)
sha256sums=('SKIP'
- 'd316105494d07fa0a46483089e707ccd24f157d7b72b6925ae6e1b47085940a5'
+ 'ecae339ef65c15ceb8151a05b97eaa3d2090147d24f4d82dc673c900ed65bcd9'
'8b47161065328dab0c9de293a8a2b4343e5c5fab464eb301f028758fb2666c6d'
- '69fa2bc03ed4f1a4aee2943ea8144cdf9573f5f8b56bb7f50278d5971f27311e'
'b2bf66b1068969e9598742d5c128cb04fd609512b0cff0ad5e25ecb6cdd35678'
'5fd3eb69bb5f9a0b88d7c1b25abdee42aa2b2fc5e1690635f60ed1f47848c46b'
'9ba3942ac1a37f6b39c98ae6592573402bf08d8376f64554d0696c0fed6fd0e2')
@@ -46,7 +44,6 @@ prepare() {
cd "$pkgname"
patch -Np1 -i ../paths-in-opt.patch
patch -Np1 -i ../running-the-server.patch
- patch -Np1 -i ../pil-tostring-is-gone.patch
# Fix permissions
chmod a-x include/*.py
diff --git a/paths-in-opt.patch b/paths-in-opt.patch
index e7a77932139b..c2f6565931d3 100644
--- a/paths-in-opt.patch
+++ b/paths-in-opt.patch
@@ -1,5 +1,5 @@
diff --git a/include/ClientGUI.py b/include/ClientGUI.py
-index 2e274f6..bbfb330 100755
+index 38e41ce..1e7fa76 100755
--- a/include/ClientGUI.py
+++ b/include/ClientGUI.py
@@ -139,7 +139,7 @@ class FrameGUI( ClientGUICommon.FrameThatResizes ):
@@ -21,10 +21,10 @@ index 2e274f6..bbfb330 100755
elif command == 'help_shortcuts': wx.MessageBox( CC.SHORTCUT_HELP )
elif command == 'import_files': self._ImportFiles()
diff --git a/include/ClientGUIDialogs.py b/include/ClientGUIDialogs.py
-index 6d6962d..6657d01 100755
+index f765182..66b7347 100755
--- a/include/ClientGUIDialogs.py
+++ b/include/ClientGUIDialogs.py
-@@ -628,7 +628,7 @@ class DialogFirstStart( Dialog ):
+@@ -630,7 +630,7 @@ class DialogFirstStart( Dialog ):
self._ok.SetForegroundColour( ( 0, 128, 0 ) )
message1 = 'Hi, this looks like the first time you have started the hydrus client. Don\'t forget to check out the'
@@ -55,7 +55,7 @@ index c7cc159..dfb34aa 100644
response_context = HydrusServerResources.ResponseContext( 200, path = path )
diff --git a/include/HydrusConstants.py b/include/HydrusConstants.py
-index 277f0fa..c0bcc4e 100755
+index b719882..be7cf52 100755
--- a/include/HydrusConstants.py
+++ b/include/HydrusConstants.py
@@ -3,9 +3,9 @@ import sys
diff --git a/pil-tostring-is-gone.patch b/pil-tostring-is-gone.patch
deleted file mode 100644
index 3d766dd6672c..000000000000
--- a/pil-tostring-is-gone.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-diff --git a/include/ClientRendering.py b/include/ClientRendering.py
-index aed4bfd..572664b 100644
---- a/include/ClientRendering.py
-+++ b/include/ClientRendering.py
-@@ -53,7 +53,7 @@ def GenerateHydrusBitmapFromPILImage( pil_image, compressed = True ):
- format = wx.BitmapBufferFormat_RGB
-
-
-- return HydrusBitmap( pil_image.tostring(), format, pil_image.size, compressed = compressed )
-+ return HydrusBitmap( pil_image.tobytes(), format, pil_image.size, compressed = compressed )
-
- class RasterContainer( object ):
-
-diff --git a/include/HydrusImageHandling.py b/include/HydrusImageHandling.py
-index bada4c1..1aedf53 100644
---- a/include/HydrusImageHandling.py
-+++ b/include/HydrusImageHandling.py
-@@ -121,7 +121,7 @@ def GenerateNumPyImageFromPILImage( pil_image ):
-
- ( w, h ) = pil_image.size
-
-- s = pil_image.tostring()
-+ s = pil_image.tobytes()
-
- return numpy.fromstring( s, dtype = 'uint8' ).reshape( ( h, w, len( s ) // ( w * h ) ) )
-