summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD13
-rw-r--r--cython-workarounds.patch57
-rw-r--r--paths-in-opt.patch10
-rw-r--r--running-the-server.patch4
5 files changed, 34 insertions, 62 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b68a91ec16a9..cb012fac96dd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hydrus
pkgdesc = Danbooru-like image tagging and searching system for the desktop
- pkgver = 168
+ pkgver = 170
pkgrel = 1
url = http://hydrusnetwork.github.io/hydrus/
install = hydrus.install
@@ -22,10 +22,12 @@ pkgbase = hydrus
depends = python2-potr
depends = python2-flvlib
depends = python2-socks
+ depends = python2-psutil
+ depends = python2-send2trash
optdepends = ffmpeg: show duration and other information on video thumbnails
optdepends = miniupnpc: automatic port forwarding
options = !strip
- source = hydrus::git+https://github.com/hydrusnetwork/hydrus.git#commit=e843462c5e3722489c9b96b94a94d26e19354a83
+ source = hydrus::git+https://github.com/hydrusnetwork/hydrus.git#commit=cc3f59732186848c80799b010c1ef412a866a50a
source = paths-in-opt.patch
source = running-the-server.patch
source = cython-workarounds.patch
@@ -33,9 +35,9 @@ pkgbase = hydrus
source = hydrus-server
source = hydrus.desktop
sha256sums = SKIP
- sha256sums = d46fb9021fa8bc0b19a2911ebf0282f8cf73c36683ea7b7148b3a7fc004a8170
- sha256sums = 4cac6ffb5c9b219129d29a7d7630a13da7a80078710a26b7004caae151e904ce
- sha256sums = 21b6eaa34e32b9bada53299537d7adbf1884322dca11d66f6cc4c55c65443ba0
+ sha256sums = 83a77de17be848f58b549d43ca6ef073a0209090c64a210743c9fbed672e1852
+ sha256sums = b039650432e3031a4efcad2d2e999d51d5dec94fbe1c30b7f522015fead0e531
+ sha256sums = b7174fb3509d89b1f15ccdcdc9c419be79161ff8bff0642bbf1d6effc8fb7730
sha256sums = b2bf66b1068969e9598742d5c128cb04fd609512b0cff0ad5e25ecb6cdd35678
sha256sums = ac7254e3cdb359ebae302655b72b9f74b85d9e817c326fa28173791b3fb4f114
sha256sums = 9ba3942ac1a37f6b39c98ae6592573402bf08d8376f64554d0696c0fed6fd0e2
diff --git a/PKGBUILD b/PKGBUILD
index d8e330475e4d..58ed17d63ec4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@ $build_cython || options=(!strip) # Don't strip libs because there aren't any;
DOC_DIRS=(opt/hydrus/help)
pkgname=hydrus
-pkgver=168
+pkgver=170
pkgrel=1
pkgdesc="Danbooru-like image tagging and searching system for the desktop"
arch=(any)
@@ -21,12 +21,13 @@ license=(WTFPL)
url=http://hydrusnetwork.github.io/hydrus/
depends=(python2 wxpython opencv python2-beautifulsoup4 python2-yaml
hsaudiotag python2-pypdf2 python2-pafy python2-lz4 python2-numpy
- python2-twisted python2-pillow python2-potr python2-flvlib python2-socks)
+ python2-twisted python2-pillow python2-potr python2-flvlib python2-socks
+ python2-psutil python2-send2trash)
makedepends=(git)
$build_cython && makedepends+=(cython2 parallel)
optdepends=('ffmpeg: show duration and other information on video thumbnails'
'miniupnpc: automatic port forwarding')
-source=("${pkgname}::git+https://github.com/hydrusnetwork/${pkgname}.git#commit=e843462c5e3722489c9b96b94a94d26e19354a83"
+source=("${pkgname}::git+https://github.com/hydrusnetwork/${pkgname}.git#commit=cc3f59732186848c80799b010c1ef412a866a50a"
paths-in-opt.patch
running-the-server.patch
cython-workarounds.patch
@@ -34,9 +35,9 @@ source=("${pkgname}::git+https://github.com/hydrusnetwork/${pkgname}.git#commit=
hydrus-server
hydrus.desktop)
sha256sums=('SKIP'
- 'd46fb9021fa8bc0b19a2911ebf0282f8cf73c36683ea7b7148b3a7fc004a8170'
- '4cac6ffb5c9b219129d29a7d7630a13da7a80078710a26b7004caae151e904ce'
- '21b6eaa34e32b9bada53299537d7adbf1884322dca11d66f6cc4c55c65443ba0'
+ '83a77de17be848f58b549d43ca6ef073a0209090c64a210743c9fbed672e1852'
+ 'b039650432e3031a4efcad2d2e999d51d5dec94fbe1c30b7f522015fead0e531'
+ 'b7174fb3509d89b1f15ccdcdc9c419be79161ff8bff0642bbf1d6effc8fb7730'
'b2bf66b1068969e9598742d5c128cb04fd609512b0cff0ad5e25ecb6cdd35678'
'ac7254e3cdb359ebae302655b72b9f74b85d9e817c326fa28173791b3fb4f114'
'9ba3942ac1a37f6b39c98ae6592573402bf08d8376f64554d0696c0fed6fd0e2')
diff --git a/cython-workarounds.patch b/cython-workarounds.patch
index dd5531731058..5afa147b7e32 100644
--- a/cython-workarounds.patch
+++ b/cython-workarounds.patch
@@ -1,8 +1,8 @@
diff --git a/include/ClientDB.py b/include/ClientDB.py
-index e0abe97..ab8b28f 100755
+index bb9593f..a499ef0 100755
--- a/include/ClientDB.py
+++ b/include/ClientDB.py
-@@ -2611,7 +2611,7 @@ class DB( HydrusDB.HydrusDB ):
+@@ -2597,7 +2597,7 @@ class DB( HydrusDB.HydrusDB ):
counts_iterable = self._c.execute( nonzero_counts_query )
@@ -12,12 +12,12 @@ index e0abe97..ab8b28f 100755
#
diff --git a/include/ClientGUICanvas.py b/include/ClientGUICanvas.py
-index 41b5c9e..293ea50 100755
+index 400b4ad..9e2a3cf 100755
--- a/include/ClientGUICanvas.py
+++ b/include/ClientGUICanvas.py
-@@ -49,7 +49,8 @@ NON_ZOOMABLE_MIMES = list( HC.AUDIO ) + [ HC.APPLICATION_PDF ]
+@@ -47,7 +47,8 @@ ZOOMOUTS = [ 20.0, 10.0, 5.0, 3.0, 2.0, 1.5, 1.2, 1.1, 1.0, 0.9, 0.8, 0.7, 0.5,
- EMBED_BUTTON_MIMES = [ HC.VIDEO_FLV, HC.APPLICATION_FLASH ]
+ OPEN_EXTERNALLY_BUTTON_SIZE = ( 200, 45 )
-def CalculateCanvasZoom( media, ( canvas_width, canvas_height ) ):
+def CalculateCanvasZoom( media, canvas_dims ):
@@ -47,7 +47,7 @@ index b8294b6..77878eb 100755
\ No newline at end of file
+
diff --git a/include/ClientGUIDialogs.py b/include/ClientGUIDialogs.py
-index b73c6ef..f1ea71c 100755
+index 3c3841a..188a8fc 100755
--- a/include/ClientGUIDialogs.py
+++ b/include/ClientGUIDialogs.py
@@ -242,7 +242,8 @@ class Dialog( wx.Dialog ):
@@ -61,7 +61,7 @@ index b73c6ef..f1ea71c 100755
wx.Dialog.SetInitialSize( self, ( width, height ) )
diff --git a/include/ClientGUIManagement.py b/include/ClientGUIManagement.py
-index 3a54639..8dcbf37 100755
+index 6ecbdef..9fde07a 100755
--- a/include/ClientGUIManagement.py
+++ b/include/ClientGUIManagement.py
@@ -66,26 +66,6 @@ def CreateManagementController( management_type, file_service_key = None ):
@@ -91,7 +91,7 @@ index 3a54639..8dcbf37 100755
def CreateManagementControllerImportGallery( site_type, gallery_type ):
-@@ -702,734 +682,6 @@ class ManagementPanel( wx.lib.scrolledpanel.ScrolledPanel ):
+@@ -706,734 +686,6 @@ class ManagementPanel( wx.lib.scrolledpanel.ScrolledPanel ):
def TestAbleToClose( self ): pass
@@ -826,42 +826,11 @@ index 3a54639..8dcbf37 100755
class ManagementPanelImport( ManagementPanel ):
-diff --git a/include/ClientImporting.py b/include/ClientImporting.py
-index 833d6a2..bb81c6c 100644
---- a/include/ClientImporting.py
-+++ b/include/ClientImporting.py
-@@ -118,26 +118,6 @@ class ImportController( HydrusSerialisable.SerialisableBase ):
-
-
-
-- def _DAEMONProcessSearchSeeds( self ):
--
-- while True:
--
-- # if searcher paused
--
-- with self._lock:
--
-- result = import_seed_queue.GetNextUnknownSeed()
--
--
-- if result is not None:
--
-- ( seed, seed_info ) = result
--
-- self._ProcessSearchSeed( seed, seed_info )
--
--
--
--
- def GetOptions( self, name ):
-
- with self._lock:
diff --git a/include/ClientMedia.py b/include/ClientMedia.py
-index 7d00441..ee77ba2 100644
+index a40543b..3641eb4 100644
--- a/include/ClientMedia.py
+++ b/include/ClientMedia.py
-@@ -1325,7 +1325,7 @@ class TagsManagerSimple( object ):
+@@ -1333,7 +1333,7 @@ class TagsManagerSimple( object ):
combined_current = combined_statuses_to_tags[ HC.CURRENT ]
combined_pending = combined_statuses_to_tags[ HC.PENDING ]
@@ -870,7 +839,7 @@ index 7d00441..ee77ba2 100644
if collapse_siblings:
-@@ -1469,4 +1469,4 @@ class TagsManager( TagsManagerSimple ):
+@@ -1477,4 +1477,4 @@ class TagsManager( TagsManagerSimple ):
self._RecalcCombined()
@@ -878,10 +847,10 @@ index 7d00441..ee77ba2 100644
\ No newline at end of file
+
diff --git a/include/HydrusData.py b/include/HydrusData.py
-index 6ebeb04..70218ff 100644
+index 1442ba2..0a831fb 100644
--- a/include/HydrusData.py
+++ b/include/HydrusData.py
-@@ -1007,15 +1007,15 @@ class ClientToServerContentUpdatePackage( HydrusYAMLBase ):
+@@ -1078,15 +1078,15 @@ class ClientToServerContentUpdatePackage( HydrusYAMLBase ):
if data_type in ( HC.CONTENT_DATA_TYPE_TAG_SIBLINGS, HC.CONTENT_DATA_TYPE_TAG_PARENTS ) and action in ( HC.CONTENT_UPDATE_PENDING, HC.CONTENT_UPDATE_PETITION ):
diff --git a/paths-in-opt.patch b/paths-in-opt.patch
index 9c50e7b0bb0e..469f15605728 100644
--- a/paths-in-opt.patch
+++ b/paths-in-opt.patch
@@ -1,8 +1,8 @@
diff --git a/include/ClientGUI.py b/include/ClientGUI.py
-index f102d86..3564325 100755
+index 26e1eb9..35f2be4 100755
--- a/include/ClientGUI.py
+++ b/include/ClientGUI.py
-@@ -134,7 +134,7 @@ class FrameGUI( ClientGUICommon.FrameThatResizes ):
+@@ -136,7 +136,7 @@ class FrameGUI( ClientGUICommon.FrameThatResizes ):
aboutinfo.SetVersion( HydrusData.ToString( HC.SOFTWARE_VERSION ) )
aboutinfo.SetDescription( CC.CLIENT_DESCRIPTION )
@@ -11,7 +11,7 @@ index f102d86..3564325 100755
aboutinfo.SetLicense( license )
-@@ -1945,7 +1945,7 @@ The password is cleartext here but obscured in the entry dialog. Enter a blank p
+@@ -1975,7 +1975,7 @@ The password is cleartext here but obscured in the entry dialog. Enter a blank p
elif command == '8chan_board': webbrowser.open( 'http://8ch.net/hydrus/index.html' )
elif command == 'file_integrity': self._CheckFileIntegrity()
@@ -21,7 +21,7 @@ index f102d86..3564325 100755
elif command == 'help_shortcuts': wx.MessageBox( CC.SHORTCUT_HELP )
elif command == 'import_files': self._ImportFiles()
diff --git a/include/ClientGUIDialogs.py b/include/ClientGUIDialogs.py
-index 465fc3e..b73c6ef 100755
+index 3c03b10..3c3841a 100755
--- a/include/ClientGUIDialogs.py
+++ b/include/ClientGUIDialogs.py
@@ -620,7 +620,7 @@ class DialogFirstStart( Dialog ):
@@ -62,7 +62,7 @@ index 90fb7ea..beb17d2 100644
\ No newline at end of file
+
diff --git a/include/HydrusConstants.py b/include/HydrusConstants.py
-index 024421b..5f62b9a 100755
+index 83942d3..927155e 100755
--- a/include/HydrusConstants.py
+++ b/include/HydrusConstants.py
@@ -3,9 +3,9 @@ import sys
diff --git a/running-the-server.patch b/running-the-server.patch
index 9bea9b6b053c..f77f0830798a 100644
--- a/running-the-server.patch
+++ b/running-the-server.patch
@@ -1,8 +1,8 @@
diff --git a/include/ClientGUI.py b/include/ClientGUI.py
-index 3564325..07b7240 100755
+index 35f2be4..86c99e5 100755
--- a/include/ClientGUI.py
+++ b/include/ClientGUI.py
-@@ -239,18 +239,7 @@ class FrameGUI( ClientGUICommon.FrameThatResizes ):
+@@ -241,18 +241,7 @@ class FrameGUI( ClientGUICommon.FrameThatResizes ):
my_scriptname = sys.argv[0]