summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD24
2 files changed, 11 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f521d1a30b5a..dd8a832101ed 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = i3lock-git
pkgdesc = An improved screenlocker based upon XCB and PAM
- pkgver = 2.13.r3.g5169138
+ pkgver = 2.14.r0.g0171394
pkgrel = 1
url = https://i3wm.org/i3lock/
arch = i686
@@ -16,7 +16,7 @@ pkgbase = i3lock-git
conflicts = i3lock
options = docs
backup = etc/pam.d/i3lock
- source = git+https://github.com/i3/i3lock#branch=master
+ source = git+https://github.com/i3/i3lock#branch=main
sha1sums = SKIP
pkgname = i3lock-git
diff --git a/PKGBUILD b/PKGBUILD
index 63ba09d97a48..571497fb4fc4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: William Giokas <1007380@gmail.com>
pkgname=i3lock-git
-pkgver=2.13.r3.g5169138
+pkgver=2.14.r0.g0171394
pkgrel=1
pkgdesc="An improved screenlocker based upon XCB and PAM"
arch=('i686' 'x86_64')
@@ -16,38 +16,32 @@ depends=('xcb-util-image' 'libev' 'cairo' 'libxkbcommon-x11')
backup=("etc/pam.d/i3lock")
options=('docs')
makedepends=('git')
-source=('git+https://github.com/i3/i3lock#branch=master')
+source=('git+https://github.com/i3/i3lock#branch=main')
sha1sums=('SKIP')
-_gitname='i3lock'
-
pkgver() {
- cd "$srcdir/$_gitname"
+ cd "$srcdir/i3lock"
git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd "$_gitname"
+ cd "i3lock"
# Fix ticket FS#31544, sed line taken from gentoo
sed -i -e 's:login:system-auth:' pam/i3lock
-
- autoreconf -fiv
}
build() {
- cd "$_gitname"
+ cd "i3lock"
- ./configure \
- --prefix=/usr \
- --sysconfdir=/etc
- make
+ arch-meson ../build
+ meson compile -C ../build
}
package() {
- cd "$_gitname"
- make DESTDIR="${pkgdir}" install
+ cd "i3lock"
+ DESTDIR="${pkgdir}" meson install -C ../build
install -Dm644 i3lock.1 ${pkgdir}/usr/share/man/man1/i3lock.1
install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE