summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD20
3 files changed, 13 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 68a1ea5da852..51d6fee63d5a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = i3wsr-git
pkgdesc = A small program to change the name of an i3 workspace based on its contents.
- pkgver = 2.0.0.r2.ge28739c
+ pkgver = 2.1.1.r5.g7792fd8
pkgrel = 1
url = https://github.com/roosta/i3wsr
arch = i686
@@ -8,6 +8,7 @@ pkgbase = i3wsr-git
license = MIT
makedepends = cargo
makedepends = git
+ makedepends = python
depends = i3-wm
provides = i3wsr
conflicts = i3wsr
@@ -15,4 +16,3 @@ pkgbase = i3wsr-git
md5sums = SKIP
pkgname = i3wsr-git
-
diff --git a/.gitignore b/.gitignore
index 75a96a7ab233..0a8a117a8d93 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@ pkg
src
*.tar.*
i3wsr-git
+*.log
diff --git a/PKGBUILD b/PKGBUILD
index 47fc29731104..81a014faa950 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
-# Maintainer : Daniel Chesters <daniel.chesters@gmail.com>
+# Maintainer : Daniel Chesters <archlinux@coin-coin.xyz>
pkgname=i3wsr-git
-pkgver=2.0.0.r2.ge28739c
+pkgver=2.1.1.r5.g7792fd8
pkgrel=1
pkgdesc="A small program to change the name of an i3 workspace based on its contents."
url="https://github.com/roosta/i3wsr"
depends=('i3-wm')
-makedepends=('cargo' 'git')
+makedepends=('cargo' 'git' 'python')
arch=('i686' 'x86_64')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
@@ -15,19 +15,19 @@ source=("$pkgname::git+https://github.com/roosta/i3wsr.git")
md5sums=('SKIP')
pkgver() {
- cd "$pkgname"
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "$pkgname"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "$pkgname"
- cargo build --release
+ cd "$pkgname"
+ cargo build --release
}
package() {
- cd "$pkgname"
- install -Dm755 "target/release/${pkgname%-git}" "$pkgdir/usr/bin/${pkgname%-git}"
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cd "$pkgname"
+ install -Dm755 "target/release/${pkgname%-git}" "$pkgdir/usr/bin/${pkgname%-git}"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
# vim:set ts=2 sw=2 et: