summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD39
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ebb57b027a92
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = ibus-hangul-git
+ pkgdesc = Korean input engine for IBus
+ pkgver = 1.5.4+r2+g24bf7fc
+ pkgrel = 1
+ url = https://github.com/libhangul/ibus-hangul
+ arch = x86_64
+ license = GPL
+ makedepends = intltool
+ makedepends = gnome-common
+ depends = ibus
+ depends = libhangul
+ depends = iso-codes
+ depends = gtk-update-icon-cache
+ depends = python-gobject
+ provides = ibus-hangul
+ conflicts = ibus-hangul
+ source = git+https://github.com/libhangul/ibus-hangul.git
+ sha512sums = SKIP
+
+pkgname = ibus-hangul-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f0498c4f9a4a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Mingi Sung <FiestaLake@protonmail.com>
+# Contributor: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Thomas Dziedzic < gostrc at gmail >
+# Contributor: Radim Hvizdák <hvizdakr at gmail dot com>
+
+pkgname=ibus-hangul-git
+_pkgname=ibus-hangul
+pkgver=1.5.4+r2+g24bf7fc
+pkgrel=1
+pkgdesc='Korean input engine for IBus'
+arch=('x86_64')
+url='https://github.com/libhangul/ibus-hangul'
+license=('GPL')
+depends=('ibus' 'libhangul' 'iso-codes' 'gtk-update-icon-cache' 'python-gobject')
+makedepends=('intltool' 'gnome-common')
+provides=(${_pkgname})
+conflicts=(${_pkgname})
+source=("git+${url}.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd ${_pkgname}
+ git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
+}
+
+build() {
+ cd ${_pkgname}
+ autoreconf --verbose --force --install
+ ./configure --prefix=/usr --libexecdir=/usr/lib/ibus
+ make
+}
+
+package() {
+ cd ${_pkgname}
+ make NO_INDEX=true DESTDIR="${pkgdir}" install
+
+ # Fix symlink
+ ln -sf ../lib/ibus/ibus-setup-hangul "$pkgdir/usr/bin/ibus-setup-hangul"
+}