summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD43
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..acc4bb35aa98
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = icu66
+ pkgdesc = International Components for Unicode library
+ pkgver = 66.1
+ pkgrel = 1
+ url = http://www.icu-project.org/
+ arch = i686
+ arch = x86_64
+ license = custom:icu
+ makedepends = python
+ makedepends = clang
+ makedepends = make
+ makedepends = patch
+ depends = gcc-libs
+ depends = sh
+ source = https://github.com/unicode-org/icu/releases/download/release-66-1/icu4c-66_1-src.tgz
+ sha512sums = 78d87bce65a7bdf7e9a19bda13e353c60846816ff34025f829d1ff15f9ac49aa6061eb192173742be0eca105684ce0e39e95656147afe848520bf60274c8d246
+
+pkgname = icu66
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..194db76babd1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer:
+
+_pkgname=icu
+pkgname=icu66
+pkgver=66.1
+pkgrel=1
+pkgdesc='International Components for Unicode library'
+arch=('i686' 'x86_64')
+url="http://www.icu-project.org/"
+license=('custom:icu')
+depends=('gcc-libs' 'sh')
+makedepends=('python' 'clang' 'make' 'patch')
+source=("https://github.com/unicode-org/icu/releases/download/release-${pkgver//./-}/icu4c-${pkgver//./_}-src.tgz")
+sha512sums=('78d87bce65a7bdf7e9a19bda13e353c60846816ff34025f829d1ff15f9ac49aa6061eb192173742be0eca105684ce0e39e95656147afe848520bf60274c8d246')
+
+build() {
+ cd "${_pkgname}/source"
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --sbindir=/usr/bin
+
+ make
+}
+
+check() {
+ cd "${_pkgname}/source"
+
+ make -k check
+}
+
+package() {
+ cd "${_pkgname}/source"
+
+ make DESTDIR="${pkgdir}" install
+
+ rm -rf "${pkgdir}"/usr/{bin,include,share,lib/{pkgconfig,*.so,icu/{current,Makefile.inc,pkgdata.inc}}}
+
+ # install license
+ install -Dm644 "${srcdir}"/"${_pkgname}"/LICENSE "${pkgdir}"/usr/share/licenses/"${pkgname}"/LICENSE
+}