summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD43
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..21a8e75cc27e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = icu68
+ pkgdesc = International Components for Unicode library
+ pkgver = 68.2
+ pkgrel = 1
+ url = http://www.icu-project.org/
+ arch = i686
+ arch = x86_64
+ license = custom:icu
+ makedepends = python
+ makedepends = clang
+ makedepends = make
+ makedepends = patch
+ depends = gcc-libs
+ depends = sh
+ source = https://github.com/unicode-org/icu/releases/download/release-68-2/icu4c-68_2-src.tgz
+ sha512sums = 24f3b7981667b37df58118f56ae76a09b719358c1efa8d6f044d28ef8df1c722a894957acadfb3c37aee39ac845893924fc3370d6bbe09875aec8d937059f84b
+
+pkgname = icu68
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1e7c57aa6735
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: akliuxingyuan
+
+_pkgname=icu
+pkgname=icu68
+pkgver=68.2
+pkgrel=1
+pkgdesc='International Components for Unicode library'
+arch=('i686' 'x86_64')
+url="http://www.icu-project.org/"
+license=('custom:icu')
+depends=('gcc-libs' 'sh')
+makedepends=('python' 'clang' 'make' 'patch')
+source=("https://github.com/unicode-org/icu/releases/download/release-${pkgver//./-}/icu4c-${pkgver//./_}-src.tgz")
+sha512sums=('24f3b7981667b37df58118f56ae76a09b719358c1efa8d6f044d28ef8df1c722a894957acadfb3c37aee39ac845893924fc3370d6bbe09875aec8d937059f84b')
+
+build() {
+ cd "${_pkgname}/source"
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --sbindir=/usr/bin
+
+ make
+}
+
+check() {
+ cd "${_pkgname}/source"
+
+ make -k check
+}
+
+package() {
+ cd "${_pkgname}/source"
+
+ make DESTDIR="${pkgdir}" install
+
+ rm -rf "${pkgdir}"/usr/{bin,include,share,lib/{pkgconfig,*.so,icu/{current,Makefile.inc,pkgdata.inc}}}
+
+ # install license
+ install -Dm644 "${srcdir}"/"${_pkgname}"/LICENSE "${pkgdir}"/usr/share/licenses/"${pkgname}"/LICENSE
+}