summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
2 files changed, 25 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 084a485f9c8a..abba812e621a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
pkgbase = idos-timetable-browser-latest
pkgdesc = Offline railway and other public transport timetable search engine by CHAPS. (Czech language by default.)
- pkgver = 1.27_lib2.9.0.0
- pkgrel = 4
+ pkgver = 1.30_lib2.11.0.0_date2023_06_08
+ pkgrel = 5
epoch = 0
- url = http://chaps.cz/eng/download/idos/zip#kotvaprg
+ url = https://chaps.cz/eng/download/idos/zip#kotvaprg
arch = i686
arch = x86_64
groups = idos-timetable
@@ -15,13 +15,13 @@ pkgbase = idos-timetable-browser-latest
optdepends = idos-timetable-lang-de: For German translation.
optdepends = idos-timetable-lang-en: For English translation.
optdepends = idos-timetable-browser-license: For the license in order to use restricted data like Czech/ Slovak bus, flight, Czech public transport.
- provides = idos-timetable-browser=1.27_lib2.9.0.0
- provides = idos-timetable-lang-cz=1.27_lib2.9.0.0
+ provides = idos-timetable-browser=1.30_lib2.11.0.0_date2023_06_08
+ provides = idos-timetable-lang-cz=1.30_lib2.11.0.0_date2023_06_08
conflicts = idos-timetable-browser
- replaces = idos-timetable-browser<=1.27_lib2.9.0.0
- source = ttakt.zip::http://ttakt.chaps.cz/TTAktual/Win/Zip/TTAKT.ZIP
+ replaces = idos-timetable-browser<=1.30_lib2.11.0.0_date2023_06_08
+ source = ttakt-1.30_lib2.11.0.0_date2023_06_08.zip::https://ttakt.chaps.cz/TTAktual/Win/Zip/TTAKT.ZIP
source = idos-timetable-browser.sh
- source = IDOS-Licence.pdf::http://chaps.cz/files/idos/IDOS-Licence.pdf
+ source = IDOS-Licence.pdf::https://chaps.cz/files/idos/IDOS-Licence.pdf
source = license-dummy.txt
source = README.datafiles.txt
source = ReadMe.cz.txt
@@ -37,4 +37,3 @@ pkgbase = idos-timetable-browser-latest
sha256sums = 297e0326240e7d61b9c9f5a8f8313ce18fde2a14af9ad1f8c1ec03b67729ab57
pkgname = idos-timetable-browser-latest
-
diff --git a/PKGBUILD b/PKGBUILD
index 5f5346dff7fc..cf3463143d89 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,24 @@
# Maintainer: dreieck
-# PKGBUILD last time manually edited: At least on 2016-12-21.
+# PKGBUILD last time manually edited: At least on 2023-09-04.
+
+url="https://chaps.cz/eng/download/idos/zip#kotvaprg"
+_zipfile="TTAKT.ZIP"
+_pkgver() {
+ # Reason for a _pkgver(): Have something to run before source download so that we can have version aware source downloads.
+ _ver="$(wget -nv -O- "${url}" | grep 'Timetable browser, version' | head -n 1 | sed -r 's|^.*Timetable browser, version ([0-9\.]+),.*library version ([0-9\.]+).*$|\1_lib\2|g')"
+ _date="$(wget -nv -O- "${url}" | tr -d '\a' | tr '\n' '\a' | sed 's|^.*File '"${_zipfile}"'\(.*\)Zip/'"${_zipfile}"'.*$|\1\n|g' | tr '\a' '\n' | grep 'Update date:' | cut -d, -f1 | sed -r 's|([0-9]+)\.([0-9]+)\.([0-9]+).|\n\3_\2_\1\n|g' | grep -E '^[0-9]+_[0-9]+_[0-9]+' | sed -E -e 's|_([0-9])_|_0\1_|g' -e 's|_([0-9])$|_0\1|g')"
+ printf '%s\n' "${_ver}_date${_date}"
+}
_pkgname=idos-timetable-browser
pkgname="${_pkgname}-latest"
epoch=0
-pkgver=1.27_lib2.9.0.0
-pkgrel=4
+_pkgver="$(_pkgver)" # This should be set _before_ sources get downloaded.
+pkgver="${_pkgver}"
+pkgrel=5
pkgdesc="Offline railway and other public transport timetable search engine by CHAPS. (Czech language by default.)"
arch=('i686' 'x86_64')
-url="http://chaps.cz/eng/download/idos/zip#kotvaprg"
license=('custom')
groups=(
@@ -42,12 +51,12 @@ conflicts=("${_pkgname}")
replaces=("${_pkgname}<=${pkgver}")
-_target="ttakt.zip"
+_target="ttakt-${_pkgver}.zip"
source=(
- "${_target}::http://ttakt.chaps.cz/TTAktual/Win/Zip/TTAKT.ZIP"
+ "${_target}::https://ttakt.chaps.cz/TTAktual/Win/Zip/${_zipfile}"
"idos-timetable-browser.sh"
- "IDOS-Licence.pdf::http://chaps.cz/files/idos/IDOS-Licence.pdf"
+ "IDOS-Licence.pdf::https://chaps.cz/files/idos/IDOS-Licence.pdf"
"license-dummy.txt"
"README.datafiles.txt"
"ReadMe.cz.txt"
@@ -66,9 +75,8 @@ sha256sums=(
"297e0326240e7d61b9c9f5a8f8313ce18fde2a14af9ad1f8c1ec03b67729ab57"
)
-
pkgver() {
- wget -nv -O- "${url}" | grep 'Timetable browser, version' | head -n 1 | sed -r 's|^.*Timetable browser, version ([0-9\.]+),.*library version ([0-9\.]+).*$|\1_lib\2|g'
+ printf '%s' "${_pkgver}"
}